PR55-34 Basic Configuration Via PR55-17A

now we have confirmed that all the radios have same settings they should talk to each other.
If the repeater is installed between sensor and gateway, it should behave like this
Sensor >>> Repeater >>> Gateway

are you still getting data on the serial terminal.

Also by default sensor sends data in broadcast mode. change that to unicast.
node red has an option to set destination address.

  1. it should be the mac address of the sensor
  2. if its powered on it will act as repeater and will push data to ethernet port at same time. You can open the TCP/IP socket and should se incoming data. ( if sensor are sending in broadcast, if they are sending in unicast data will get repeated but wont show up on terminal)
  3. not sure what you mean
  1. are you still getting data on the serial terminal.
    I did initially but then it failed.

  2. Also by default sensor sends data in broadcast mode. change that to unicast.
    node red has an option to set destination address.
    ok I see how to set the full MAC address destination address in node-red.

I now get data through this modem in USB mode!

So if I understand correctly, no settings need to change when I change modem jumpers back to ethernet mode?

that is correct…

We successfully got data in USB mode through enabling Destination Address and specifying the full MAC address (unicast mode). If I understand the MAC address is to be just the last 8 characters without colons, eg
422a353c for the address 00:13:a2:00:42:2a:35:3c
is that correct?

After switching jumpers back to ETH mode I have no data. Any ideas?

correct

because local data will be router to ETH not usb but it modem will still act as repeater.

but I don’t get ANY data from that sensor in ETH mode, so how do I resolve this?

i think it will be best to get on a call and take a look.

agreed. what times tomorrow work best for you?

@Bhaskar Regarding the RS485 converter: we have the “standard” version, but according to the introduction document, this simply passes the 485 packet, wrapped in the Digi API frame, directly out the RS485 serial. This doesn’t seem like it would work well with a “dumb” Modbus device, connected to that RS485, since that device cannot unwrap the RS485 packet from within the Digi API frame. Or am I missing something? Thanks.

can you share a picture of rs485 modem ?

this one is a gen 2 device and has option to change mode of operation on the FLY.
the default mode is auto encoder. you can use is a dumb wireless to rs485 converter.

@Bhaskar thanks for the great session with @jacob last Friday. Unfortunately we are no longer getting data even though the modems are online and settings have not changed. Can we get another troubleshooting session scheduled?

We have modems working now!
To recap, we changed on the modems:
• Baud rate to 115200
• TCP to TCP SERVER

On the Sensors:
• Changed connection from SERIAL to TCP
• Set each sensor to have the TCP:2101 address of the target modem
• Set each sensor to have the Destination Address of the target modem

@Bhaskar After getting modems to work as intended, we moved the Gateway to the target location and within range of the RS485 converter, but still no data. Can you advise next steps? This is our last piece of the puzzle before we can scale the system.

did you confirm if the Modbus command we are sending is correct?
if that’s not correct then there will be no response.

I believe we were getting responses back from the flow meter during our last session, and I’ve seen appropriate responses returned since then. It just seems to go away after a while. Almost as if something powers off after a while.

We may try connecting the Modbus device directly to a serial port on the gateway (Edge EG5120), but I have two questions: 1) which device connects to the 3-pin external connector (I’m guessing COM2) and 2) I’ve tried setting COM2 to RS485 mode using the configuration interface for the gateway, but it won’t accept this change unless I set up TCP parameters. I’m confused because I’m not trying to set up a network serial interface, just RS485 to the external connector. Thanks.

The gateway rs495 port is bit tricky to use. @jacob has used it in past.

The new RS485 firmware sends health msg after user defined interval.

Can you clarify? I’m not sure what you’re asking me to do. I just want to use the rear serial connection as as a direct Modbus (RS-485) connection. Thanks.