PR55-34 Basic Configuration Via PR55-17A

Hello, we have previously used the PR55-17A modem to configure the baud rate and Pan ID of the PR55-34 devices using the NCD io Xbee to RS 485 converter utility.

However, with this latest set of PR55-34, the modem will not recognize the new PR55-34 on the same default pan ID. I’m able to connect to the older smaller PR55-34 with no issues still using the same methods.

I noticed now with the new larger PR55-34 units, Alpha Station does recognize them(will not recognize the old ones that work with NCD io Xbee to RS 485 converter utility). However, I cannot seem to get the PR55-34 units into configuration mode. Upon being prompted to by alpha station, nothing ever changes after pressing the R button and holding the C button for 6 seconds. I noticed, no LED comes on when pressing the C button, like in the video. The view and setup buttons for the device are greyed out in my alpha station unlike in the video.

This is the first time I’ve gotten Alpha station see a remote device.

Do you have any suggestions for configuring the PR55-34, I would like to change the RS-485 Baud Rate and the Pan ID.

i will recommend checking out this tool

This is the method that works great on all the original PR55-34 (Auto Encoder) I have. However, I just ordered 6 more PR55-34 (Auto Encoder) for an expansion to the project. This method is not working for the new 6, but does still work with one of the older set I have. The newer ones are in a slightly larger enclosure.

The odd thing is the newer set of 6 do get recognized by alpha station, so I know the default Pan ID is correct.

Also the RS LED on the PR55-17A modem comes on whenever a new device is powered on, further indicating that the Pan ID is set the same.

I got it. Yes, this tool wont work with the new one. new one can be configured using node-red.

can you share the baudrate you want to use and the pan id ?
do you have serial terminal tool installed on your pc ?
if not can you install XCTU ?

I have Digi XCTU, Putty, and SecureCRT

open xctu terminal

the command to set the PAN id is
7E 00 15 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F7 05 00 00 00 7F FF 7A
This command will set the PAN id to 7FFF.

command to set baudrate
7E 00 17 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F4 20 00 00 17 00 01 C2 00 06
This will set the baudrate to 115200.

this is how the new hardware work
after boot the device stays in command mode for 1 min. in the command mode users can send any command to set any parameters.

1 Like

Thank you, the command to change PAN ID is working.

Could you post the command to change the baudrate to 19200 and back to 9600.

Could you post the command to change the Pan ID to 1103.

PAN ID – 1103
7E 00 15 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F7 05 00 00 00 11 03 E4

Baudrate 9600
7E 00 17 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F4 20 00 00 17 00 00 25 80 24

19200
7E 00 17 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F4 20 00 00 17 00 00 4B 00 7E

2 Likes

Thank you, I thought this was so, but yesterday no matter the command, the board would just change PAN ID to 7FFF.

I tried it again today, knowing the commands are correct and it is working with no issues. Not sure where the error was. All the newer units work with the older style units flawlessly.

how do you configure with node-red?

I am trying to configure a third party water sensor which is wired to the NCD PR55-34 (on a roof top) which is wirelessly reporting to an NCD wireless-ethernet modem (also on roof) as a repeater via ethernet to an NCD gateway (IT closet)

can you share the node red flow you are using to send the rsm485 commands ?

Attached is the whole flow - almost all NCD devices.

Screenshot is of the two attempts to make the rsm485 report in.
liveLCAflows240429.json (83.6 KB)
PastedGraphic-1

in the flwo you have the rs485 nodes

these are configured wrong.

attaching the flow which will read reg 0-10 of the flow meter

[
    {
        "id": "40c019fbc6fa7a55",
        "type": "ncd-gateway-node",
        "z": "d8c4cc4908f9d73e",
        "name": "",
        "connection": "fb1c05801bea5c04",
        "unknown_devices": true,
        "outputs": 2,
        "x": 450,
        "y": 1280,
        "wires": [
            [
                "7158c2f7f3bfcd31"
            ],
            [
                "4a0c8ca08fc11660"
            ]
        ]
    },
    {
        "id": "f598a0b8d120a50c",
        "type": "inject",
        "z": "d8c4cc4908f9d73e",
        "name": "read flow meter",
        "props": [
            {
                "p": "payload.address",
                "v": "00:00:00:00:00:00:FF:FF",
                "vt": "str"
            },
            {
                "p": "payload.data",
                "v": "[01, 03, 00, 01, 00 , 10, 148,13]",
                "vt": "bin"
            }
        ],
        "repeat": "",
        "crontab": "",
        "once": false,
        "onceDelay": 0.1,
        "topic": "",
        "x": 160,
        "y": 1220,
        "wires": [
            [
                "40c019fbc6fa7a55"
            ]
        ]
    },
    {
        "id": "7158c2f7f3bfcd31",
        "type": "debug",
        "z": "d8c4cc4908f9d73e",
        "name": "debug 113",
        "active": true,
        "tosidebar": true,
        "console": false,
        "tostatus": false,
        "complete": "false",
        "statusVal": "",
        "statusType": "auto",
        "x": 680,
        "y": 1280,
        "wires": []
    },
    {
        "id": "4a0c8ca08fc11660",
        "type": "debug",
        "z": "d8c4cc4908f9d73e",
        "name": "debug 114",
        "active": true,
        "tosidebar": true,
        "console": false,
        "tostatus": false,
        "complete": "false",
        "statusVal": "",
        "statusType": "auto",
        "x": 690,
        "y": 1340,
        "wires": []
    },
    {
        "id": "fb1c05801bea5c04",
        "type": "ncd-gateway-config",
        "name": "PORT20",
        "comm_type": "serial",
        "ip_address": "",
        "tcp_port": "2101",
        "port": "COM20",
        "baudRate": "115200",
        "pan_id": "7FFF",
        "rssi": true
    }
]

type or paste code here

still not working. Although I suspect we must first solve for the repeaters. We are now powering them via USB and still nothing. This is becoming a difficult situation.

if they are not working as repeaters which means there are setting diff between sensors radio and repeater radio.

connect the repeater radio to XCTU and share screenshots of its setting

1 Like

The installation is in another country, and since I could not successfully complete installation while there, I have to do this remotely. I had our partner install XCTU on the local machine and I do have remote control of that machine. However I cannot seem to access the config settings of the radio (via ethernet). However I do have an error log from the gateway. I also have the settings of the repeater modem from the local control panel.




last image is gateway

xctu does not work over ethernet.
there are 2 jumpers for selecting the interface, set the jumpers to USB and connect the modem to pc over usb.
check sleep mode setting.

can we please set up a live session to review the settings of the ethernet modems being used as repeaters?

I sent you the meeting invite. we will need access to the modem and a pc with xctu.

Thanks for the informative meeting!
For those checking this thread out later, I understand that in order to have multiple modems reporting to the same network we need to FIRST set up modems in USB mode (moving internal jumpers) and verify settings with XCTU that all modems are on the same configuration. Most common cuplrits for network issues are resolved with the following confirmed settings:

  1. Sleep settings need to be “OFF”
  2. Network ID needs to be same on all devices: “7FFF”
  3. Encryption ID needs to be “Enabled”
  4. Encryption key needs to be “default”
  • These settings are only accessible via USB by XCTU
  • Taking screen shots of the confirmed settings would be best practice
  • Factory reset will do same thing.