PR55-34 Basic Configuration Via PR55-17A

Hi,

You will need to configure the RS-485 port through the web configuration UI and then connect to it as a modbus TCP.

Log in to the web configuration interface of the gateway
Navigate to Interface > Serial Port
Click the edit icon next to COM2
Change these settings:
Type: RS485
Application Mode: Modbus RTU Gateway or Transparent
Protocol: TCP Server
Local IP: 127.0.0.1
Port: 5556

Then from node-red or whatever application you can connect to the RS-485 port using modbus TCP or just TCP on the host of localhost on port 5556

Got it - thanks! And some more characters to satisfy the bots…

1 Like

I forgot to mention that you’ll need to make sure the port is enabled through the web configuration interface. Its disabled by default.

Gotta keep those bots happy.

Just got a new PR55-17B modem in and started setting it up using XCTU, using the USB connection. Everything was working fine, but at some point XCTU just would no longer find the modem. I’m not sure what I was doing at the time, but had probably just reset or reconnected the modem. I’ve tried using Alpha Station, but “Sensor View & Setup” times-out and says “Unable to Communicate with Modem”.
I can see the com port show up when I plug it in, so the com port should be good. Tried “recover modem default settings”, see a few flashes on the TX LED, but otherwise doesn’t seem to have much effect.
Anything else I can try? Thanks.

Hi Tom,

Can you make sure the jumpers in the modem are set to the USB position?

I would also recommend disconnecting power, USB, and Ethernet from the modem and power cycling the PC just to make sure no comms are stuck open on the PC or on the modem.

Yes, have the top off and have the jumpers on USB.
I’ve power cycles and reset the modem multiple times. I’ll try resetting the PC, but I’ve tried running XCTU from both my Windows desktop and my Linux laptop with no success.

@jacob Sorry for the delay - I’ve reset both, but no change. I do see the LEDs blinking as I do the search from XCTU, so it looks like the port is good, it’s just not talking. Also still getting “unable to communicate with modem” from Alpha Station (although I can see the TX LED flicker once per second after clicking on “sensor view and setup”). Is there a “factory reset” on this? Tried “recover modem default settings” in Alpha Station, with no effect - in fact don’t even see any activity on the TX or RX LEDs after clicking that.
Thanks.

Hi Tom,

XCTU causes the LEDs to blink, but you’re not getting a response correct?

What baud rate are you attempting to use to open the port?

Can you send a top down photo of the modem with the lid off?

Just tried XCTU again, this time using the “add device” instead of “discover”, and it connected to the wireless modem, and selecting the device causes configuration parameters to be read - although it resets between each AT value read, so takes a very long time to complete this task (maybe 30 minutes?). Both “add” and “discover” were set to use COM5, 115200,8,n,1. It also indicates new FW available (300D to 3012).
Still no luck using Alpha Station, though that might be because the only wireless device I have to communicate with is the RS-485 converter. OK, just tried again with the network cable, and it does discover the device on the network now, though selecting it, and clicking on “sensor view and setup” reports “unable to communicate to modem”.

Hi Tom,

It sounds like the board may have the wrong settings for some reason.

Can you let me know what the SM (Sleep Mode) setting is set to? For a modem or gateway it should be set to Normal [0]. If it is set to Async Pin Sleep [1] then this module was meant for a sensor and would explain the constant sleeping. If it is set to Async Pin Sleep I would recommend change that to Normal and writing that single settings using the icon just to the right of it.

You can recover the settings back to our default settings by applying this configuration to it: https://github.com/ncdcommunity/ncd.io-IoT-Wireless-Sensor-Recovery-Files/raw/master/Xbee3_PC.xpro

You can apply the profile linked above from XCTU. Connect to the module and above where you see the settings you should see a Profile icon, click on that and choose apply configuration profile, choose the previously downloaded profile.

The wireless modem is set to “no sleep” (0).

So does “create profile” save a copy of the configuration for the modem? That would be nice to have. Thanks for the .xpro file, that might come in handy just to make sure some oddball configuration didn’t get in there. Does that default the key value (KY) too?

Is it normal for XCTU to reset the modem for e.v.e.r.y. configuration value it downloads? I know this isn’t NCD software, but just curious.

Hi,

Create profile does create a profile file with your current settings. I generally don’t recommend this in conjunction with our sensors as the onboard processor of our sensors resets a few key settings on these modules on boot. You would want to use Node-Red or our configuration API to make these changes.

I can go into more detail about the why or how of the above, but as for the issue.

Yes it will reset the KY value. This is one of the settings that is reset on boot of the sensors.

This sounds like a power issue. First I would try a different USB port. If you’re using a USB hub try to connect directly to the PC.

Secondly I would try providing 12VDC power via the external power barrel connector.

Let me know if either of the above helps.

I plugged in the power adapter along with the USB, and tried two different computers and OS’s (Windows 10 and Linux Ubuntu). Both work somewhat. Also tried connecting directly to USB ports on both my Windows desktop and Linux laptop, with a couple different cables. I can only convince XCTU to discover the device if I add it with the specific USB port, and typically after a reset. On both systems each parameter read requires a reset, and on the Linux machine I have to hit the reset button. Since I’m unable to connect to it over the LAN (with node-red), I thought I’d try writing the KY key value, but it fails before it completes.
Appreciate your efforts on this.

Hi,

Unfortunately it sounds like the issue may be on the hardware itself. The only thing I could recommend is an RMA so we can get the unit back and repair/replace it as needed.

You can request an RMA at: NCD Login - NCD.io