Blinking Red Light on Wi-Fi Micro Gateway MQTT (PR55-21)

Hello, I’ve been having issues with a new Wi-Fi Micro Gateway MQTT (PR55-21), I able able to get the unit connected, but it will not stay in a green light state. The unit will connect (and stay connected to) Wi-Fi but the light will transition to a single blinking red.

My MQTT setup is rather basic (functionally/in-active use) no-auth Mosquitto mqtt on default port on local network. I’ve confirmed the mqtt is listening on all interfaces. I’ve also tried different (simpler) local network setups to include a wireless router directly connected to the target mqtt box.

On the wi-fi router (1 time) was able to see network traffic shows the gateway either makes single attempt or not attempt at all to connect to mqtt. (But having difficulty repeating that.) Typically seems like no traffic occurs between gateway and broker (as seen via debug monitoring of mqtt traffic on the broker)

I have tried the normal config-5 sec (when powered on) to re-attempt, as well as holding-config when when applying power (to same end result) of green light transitioning to single blinking red.

I do have a number of sensors (not yet setup), was starting with the gateway. If this is not the correct process I may need some pointers to documentation.

Following the current setup guide found online (using DHCP), leaving all fields blank not used, IP for mqtt broker, not domain. My Wi-Fi networks in use are also 2.4 GHz with only alphanumeric characters.

Can you please provide screen shots of the configuration you are saving to the MQTT Gateway?

Also try using the same credentials on MQTT Explorer here to test connection from your computer to the Mosquitto Broker:

Lastly I can confirm these MQTT Gateways can connect to Mosquitto no problem. I have documentation available here:

Thank you,
Travis Elliott

MQTT explorer was success connecting and seeing traffic. (Also posted that view below)
thanks Travis here is the attached view from setup/config:


Any other thoughts or things to try @TravisE_NCD_Technica ? I saw in this post something else I hadn’t tried. MQTT WIFI Micro Gateway (Wifi Module Failure) (had me wondering if I could swap in and borrow some of the boards from my sensors to try in the Gateway to rule out that as possible cause?)

Try putting the IP address into the Domain field rather than the IP field and see if that resolves it. I’ve seen that be an issue in the past.

No joy. Put in the Domain & IP field. The web-gui will not allow the IP field to be blank and just use the domain field.

Put in the IP field. It will be ignored. (on IP) did allow real IP for domain (to be submitted.) Still single-blink red light after green (after a brief solid green.)

When you say “brief solid green”. How long would you estimate the LED is green? 2 seconds, 30 seconds, etc? I’m wondering if the MQTT Broker is initially accepting connection from the gateway but then disconnecting for violation of topic/payload format or if it initially authenticates but then rejects the connection.

Just for diagnostic purposes I would recommend connecting the MQTT Gateway to the BeeBotte broker as explained in this guide:

BeeBotte is free to use and would verify if there is any issue with the MQTT Gateway. There are many things to go wrong working with Mosquitto.

From a cold-start the light blinks white for about 3 seconds, then is green for 5-7 seconds, before transitioning to blinking red. Similar when immediately configured.

I’m subscribed (mosquitto_sub) to the broker with debug (-d) on all topics (#) and see no client connect or any activity indicating the unit is making a connection.

I think I may have shared before, I can confirm during all of this the unit is on the Wi-Fi network (can be pinged at least.)

I’ll give that BeeBottle a go right now and report back. Can you elaborate on what could go wrong with Mosquitto. I have used it a bunch (especially in these local simple configs) and almost never had any issues that I can think of.

I know when I worked with Mosquitto the configuration file could be a real pain especially if there was any sort of authentication. Also having it open so clients with any client ID can associate is not super intuitive, there was a setting for that. BeeBotte is really simple, but you do have to configure the topic and configure the Gateway to publish to the topic properly. That’s covered in the guide.

Retested with beebottle, very good docs btw. Same result unfortunately…

Happy to share the Mosquitto conf as well if helpful (for the basic setup), agree on it taking a bit of initial figuring out. But way-past that at this point. (Using it widely without issue)

This does seem like something post Wi-Fi connect, pre-mqtt connect if there are some other options to troubleshoot.

Are the the little Digi/Xbee-Pro S39 internal radios the same regardless if sensor or gateway? Not sure if that is good next step, or other possible ways to debug/troubleshoot as-is?

The Digi XBee modules in the Gateway and the sensor are the same, however the configuration in them is different so you cannot just swap them. They would require reconfiguration which would require a USB adapter like this:

As one last troubleshooting request can you send a top down photo of the Gateway with the lid removed and power connected?

For sure here is a pic below. Don’t have one of those devices. Aside from sensors only other equipment purchased on original order was a 900HP-S3B (haven’t used yet.)

Also, not sure if helpful in troubleshooting, but I also haven’t connected sensors to the gateway. Would that be another way to test anything? (Not sure if that is something that typically happens before or after mqtt-connection.)

This only happens maybe once a year or so but given this information I have to assume the XBee module in this MQTT Gateway is either bad or configured incorrectly. The Processor is not able to communicate with the XBee module which is why it is flashing the error code.

I would recommend sending the device in for warranty repair by completing the RMA form here. After completing the RMA form you will receive an email with instructions on returning the device for repair:

Be sure to Note on the Issue Description on the RMA:
XBee module does not appear to be communicating with processor as discussed with Travis on forum post “Blinking Red Light on Wi-Fi Micro Gateway MQTT (PR55-21)”. Assuming incorrect configuration in XBee module or XBee module has failed.

Sounds good. You may also see and order come through from me (for a new one.) I’m optomistic this will all work out well.

I’ll need multiple over time, and concerned my whole project now on hold due to this one device.

I just found your new online order. I sent a message to our production manager and testing department manager to bring that order to me prior to shipping so I can make certain it is good before it ships.

Do you want us to refund the unit you are sending back or do you just want it repaired and returned?

Thanks Travis. I think I’m going to still do the RMA for repair on this initial unit. I could benefit from having more than one of those units eventually.