PR55-21 Azure Gateway Blinking Red Light

I recently purchased a PR55-21 Azure Gateway and several PR52-10A sensors for a new project, and I am having trouble getting the gateway to stay connected.
I followed the configuration guides for the gateway, and I can connect successfully to the WIFI network. When I save the configuration with the connection string and WIFI details the green light on the gateway will turn green for a few seconds, and then transitions to a steady blinking red light. When I check the IOT hub the device shows as disconnected.

I tried a factory reset, but that did not change anything.
I thought maybe it might be my WIFI network blocking ports, so I built a node.js project to simulate sensor communication to Azure IOT hub. I ran that on the same network with the same Azure connection string and that was able to send telemetry normally, so I think the WIFI network is not the issue either.

I did some more research on here and found a similar topic for a MQTT gateway.
Blinking Red Light on Wifi Micro Gateway

Is there anything else I can check to troubleshoot the issue I am having? The gateway config is basic, DHCP enabled, Azure connection string and WIFI network information.

Sorry we missed this post.

When the Red LED blinks is there a pattern like 2 flashes, 3 flashes or does it just appear to be a steady blink. That could tell us the error.

It is just a steady blink, no pattern of flashes.
When I exit configuration mode it will stay a steady green for several seconds, then a steady blinking red.

Is there anything else that I can do to help troubleshoot my issue?
I would love to get this project moving forward.

Can I get an update on this please? If I need to RMA the unit and get a new one then I would like to get that process moving forward.


If the LED is red then it indicates an issue with connecting to the WiFi network or it is having issues connecting to Azure.

If you’re sure that both the wifi network settings and Azure connection information is correct you can request an RMA at: NCD Login -

I do not think that the Wifi network or azure connection string is wrong, I have triple checked that.
I can see a connection being made on the access point for the WiFi, and can get a connection in azure for a second.
I build a node.js project to test the connectivity and on the same wifi with the same azure connection string that works perfectly, which is why I think it is something with the gateway itself.
Also, the issue I am seeing matches the issue Here perfectly and that turned out to be an issue with the gateway itself.