Setting Static IP on ZADSR16 ProXR

We recently purchased a ZADSR16 10A ProXR Relay, and are trying to set it to have a static IP.

According to https://ncd.io/ncd-gen3-ethernet-module-user-guide/ we should attach a jumper to the 2 pins on the left of the ethernet port, still on the ethernet module and power on.

From there I’ve used the NCD config tool and it give a 169.254.X.X address which I believe is the device, the Apply Settings and Reset options can be used. I set it to permanently have the IP of 192.168.1.88 and removed power from the board, removed the jumper, and turned it back on.

I’ve tried using a webpage at 192.168.1.88 and get a can’t reach this page, as well as the NCD Base Software on the Network setting. Neither seems to be able to get info from the board.

I’ve also reset the board and did all these steps over again. Am I missing something in configuring this?

Hi Dan,

Can you confirm that the IP address of 192.168.1.88 that you assigned to the device is on the same network as your PC?

I’m hoping for it to be setup as a local network - I have the board connected via an usb-ethernet adaptor and an ethernet cable to the computer so it should be on the same local network.
I’ve been able to connect to other similar devices in this manner.

Hi Dan,

If the PC this is connected to has another WiFi or Ethernet network connected to it that has internet your OS is probably defaulting to trying to use the internet enabled network. This means IP communication requests will try to go through this network.

Unfortunately we don’t have any experience using a USB to Ethernet adapter for direct connection to these boards. You can try again, but disable all other network adapters on the PC to see if this enables communications.

I disconnect from all other networks, reset the board (held the button to right of ethernet port for 5 seconds) and tried to do above - got the same results.
For the adaptor - I’m able to get both lights on the ethernet port on both sides and able to get this info through the config tool, so I’m thinking they are able to communicate to some extent.

Is this something the we are likely doing wrong or should we be looking at a return to get another relay and/or ethernet adaptor?

hi,
if you want to set the static ip then you dont need to install the jumper. use the config utility and enter your ip settings.
after that click apply settings.

Using the Config tool without the jumper leads to the same result. Cannot open IP in webpage and NCB Base gives a “Device Identification Failed”

reflash the firmware. use the ncd config utility from the link

If the config tool sees it then you should be able to access it. It is difficult to say what is causing the issue because there are also configurations on your network adapter. One thing I’m seeing is that your network adapter’s ip address is on 169.254.177.94 and the Ethernet module’s IP address is 192.168.1.88 which puts them into different subnets. You can try putting the ethernet module into the same subnet as your adapter: 169.254.177.x with a gateway of 169.254.177.1

This may resolve the issue.