Predictive Maintenance Sensor V3 Alpha Station and Node Issues


I’m having a few issues with Alpha Station and Node Red with the new PMS V3. I’m using the latest version of Alpha Station and the NCD nodes in Node Red (Running on Win10 PC).

I was able to configure the sensors using Alpha Station V by using the ‘Basic Settings’ button only. No data showed up in the datagrid before or after configuration. Using the new version V there was still no data in the datagrid but I couldn’t get into Config Mode using either config button. I tried multiple times with multiple sensors. This holds true for all 4 of my PR55-61PM_BTR’s.

Here is the configuration I did with the older version of Alpha Station. I’m pretty sure it stuck because I was able to read it back after I wrote it. This screenshot was taken about an hour after I initially set it and restarted Alpha Station As I mentioned I couldn’t even get into config to get a read in the new version.

In Node Red the new sensors show as running but I am not getting data from them, not in the database or even using the Debug node.

Thanks in advance for your help!

to configure v3 use node red. make sure you set the delay value to zero and use interval value to set the data transmission interval.

Thanks, Bhaskar. Where would the Interval setting be?

select condition based sensor.


Condition Based Sensor is not listed as a Sensor Type.

you might need to update the firmware .

I believe it should be labeled “Condition Based/Predictive Maintenance Sensor”. It will be towards the end of the list. If you do not see that listed then update ncd-red-wireless via the pallet manager in Node-Red.

Good morning guys,

I have updated the wireless node and ended up with this, I’m not sure what it means. The condition based option is listed now.

Do I have to change the configs of my existing sensors?
Thank you!

I forgot to mention that I have not changed anything, here is a snip of my configuration:

Hi Jeff,

You need to change the Sensor Type to Condition Based/Predictive Maintenance Sensor if these are PR55-61PM_BTR.

I ended up redoing the entire flow and got rid of the errors. All of the sensors are functioning correctly except the new PR55-61PM_BTR’s. I have tried configuring them through node-red using the settings below. After entering the settings you see below I then put them in config mode (Reset, Hold Config for 6 seconds) and let them go for 15 minutes. After the 15 minutes I hit reset. They show as running in Node Red but I’m still not getting any data to the debug node or the database. Can you take a look at these settings and tell me what I’m missing? Thanks!


Hi Jeff,

You have to put the IoT Edge computer into config mode as well. There is a little square next to your SensorGateway node, click that, the gateway is now in configuration mode. Now put the sensor into configuration mode.

Also keep in mind if you edit settings in a sensor node you must deploy after making those changes.

so the issue might be the node id number.
this sensor works like this
so it will sample after every 5 min, then it will wait for it turn to send data. node is is used to get in the line for data transmission.
so after sampling the data it will wait for 25sec*node id. so by the time it gets ready to send the data the interval timer will kick in and reset it.
set the node id like 30 and give it a go. you should get data.

Why did we do this – this sensor can also send raw time domain data. while sending raw time domain data it sends hundreds rf packet. if all sensor sends these packet at same time then we ill run info RF issues. node id helps resolve this issue

Thanks for your help guys, those last 2 posts did the trick! Have a great day!

One last quick question: I have the Delay set to 0 and the Sampling Value set to 5 Minutes but all 4 sensors are only broadcasting every 30 minutes. How can I get it set to broadcast every 5?

what are the node id ?
i just ran a test cas where my node id was set 0 and interval 5min
interval 5min

40, 41, 42, and 43.


the interval is still set to 15 min looks like. it didn’t set to 5 min.
for example lets say node is is set to 40.
then the device will send data after 15min ( interval) + node id * 25sec.
in this case the data is coming after 30 min.
if you set the node id to 0 and interval to 5 min you will see data coming after every 5 min.

I will recommend using MAC address as sensor identifier instead node id.

Hello Bhaskar, I have made the changes you suggested to all 4 of my sensors, setting the nodeID to 0 and the Sampling Interval to 5 minutes. It has gotten better but it is still at 15 minute intervals. This holds true for all 4 units.

node red sends a config log in the debug window. it shows what al commands went through. can you share that log.