PR8-24 & AnyI2C, Can't Find

I have two boards of the PR8-24 marked with MCP23008 & I2CR8G5V1. They are REV B.

I installed AnyI2C onto my Windows 10 Dell Laptop and I cannot find the device. I have confirmed that the COM4 is the correct port and I have talked with other serial devices using this computer, those had FTDI chips and so I have up to date drivers.

When pressing ‘Scan’, it takes more than a minute to respond and there are no devices found.

I have the Address on the board set to 0x20 (default) with none of the jumpers connected.

Is the i2c cable connected to i2c in port?
is the board powered up?

Both LEDs are on for I2C and Power on the PR8-24. The power is lit up on the USB-I2C board which is PR33-17.

You can select the relay board manually and see if you can communicate with the board.

@Shirui_Xu_Software_D and @ryan devloped anyi2c they might have more insight.

This sounds like a FTDI driver issue, it will be important to make sure this device is registered in your device manager. If not, please follow these instructions carefully, they were created for this particular situation:

Thank you for double checking on the drivers. As I mentioned in the first post, I do have the latest drivers. I haven’t noticed an issue mounting the port, I have been using COM4.

I ran the driver update just in-case and I am stuck at the Step 3 “Load the VCP Driver”. In Device manager there is no advanced tab or option I can see for “Load VCP”. For the USB Serial converter the available tabs are “General, Driver, Details, Events”. For the COM4 port the available tabs are “General, Port Settings, Driver, Details, Events”.

Alternative solution, I do not have a larger number of COM ports, this is the only one currently active. I am using a Dell Latitude E7250 with Windows 10.

@Bhaskar you comment of manually selecting the device. I have tried selecting the following devices inside the list, but I have not found a perfect match of the part number on the board “I2CR8G5V1”
*I2CR4x
*I2CR8G5LE_MCP230008
*I2CR8x

this one I2CR8G5LE_MCP230008.

Thank you for clarifying the device.

I restarted my computer to see if that would help, and I am still unable to connect.

@Bhaskar & @ryan1, I still need help with this.

can you share a screen shot of the error message and share a picture of the setup.

Thanks

@bhaskar, I am not getting an error message.

whats your order number ?
@ryan1 is it possible that the module got shipped without any firmware ?

I sign all order sheets on the internal order process notes, with the order number, I can check for my signature, orders are not allowed to leave unless I have signed, and I will not sign until I have validated firmware is loaded and operational. @jacobian91 please let us know your order number and I will check our internal process notes for a firmware signature.

@ryan1 Online order #299893, invoice #44592, 8/10/18

@ryan1 I have two boards of PR8-24 boards, neither is working.

Ok, firmware was last updated on the USB to I2C converter (PR33-17) on 5/7/2018, which falls within the time frame of your order. Your order was properly signed off, so it was tested good here prior to shipping.

It sounds as though the SCAN button is not finding the device, so please test different baud rates:
Please try 9600, 19200, 38400, and 57600 speeds. Let me know if any of these baud rates work correctly.

Thanks,
Ryan

@ryan1 No luck with changing the baud rates. Are there settings like ‘stop-bits’ that I need to change in the Device Manager?

@ryan1 @Bhaskar any ideas?