PR58-1_MQTT - Updating interval setting through MQTT topic has no effect


I bought this product received yesterday to get a power supplied sensor and temp values every minute at home (for heating), but also to reduce load on my system when away from home (thus switching dynamically to longer intervals, like every 15 min.).

This product has a MQTT setting topic, as explained on the product page and shown in its config UI. The JSON payload to send to this topic is supposed to be of the following form :

{"interval": 30000}

for 30 seconds.

However, sending such payloads to this topic has no effect on the sensor, the reports are still sent at the previous interval, set from the UI.

I tried to upgrade the firmware from 1.0.1 to 1.0.2 but this also fails at step 2 (upload of firmware.bin works, but the upload of spiffs.bin hangs at 80% with 400 - bad request error, and the sensor remains at. 1.0.1).

So, could you please provide a solution, either through a valid firmware, or RMA (like here for this same product) ?

Thank you.

PS : I sent more details regarding this issue through your contact form (private messages).

There was an update to the processor platform which changed some default registry sizes which lead to this bug. I investigated, identified, and corrected the bug. You can update your firmware as explained in the user guide to v1.0.3

Also the payload to update the report interval of the sensor will be:
Not interval.

Thank you,

Thanks a lot Travis, for your fast support, I confirm that I could this time upgrade from 1.0.1 to 1.0.3 and the report_interval is now updated gracefully through MQTT. :+1: Issue solved.

Suggestion : the product page should be updated accordingly for “report_interval” instead of “interval”, in the “Monitor Temperature & Humidity with MQTT.fx” section, since it’s the only place to find the info :

and it won’t match the “interval” key name from your generic doc in the blog :

1 Like