Modifying Device Sampling Interval Using the Micro Gateway Amazon AWS

Hi team,

We have purchased “AC Current Monitor” sensor, “Predictive Maintenance Sensor Plus” sensor and the “Micro Gateway” for connecting to Amazon AWS. I have followed the documentation provided by your website and was able to successfully install and test that messaged are received on AWS IOT Client Test (https://ncd.io/wifi-micro-gateway-setup-for-aws/). What we need to do is set the sampling interval for each device to something different than the default value. I noticed on the step where I connect the Gateway to WIFI and put in my AWS access key and secret. There is a “Devices” tab, and when I hold the config button on the sensor for 6 seconds, I can see the sensors appear on the list. I have clicked the configure button on the UI and changed the delay to different values. But it just does not seem to save cause when I revert back to AWS MQTT test client I did not see the messaged come in the interval I had changed. From my understanding the delay column is in seconds. So if I set the value to 1 it should send a single every second. I have attached screenshot from the screen I have just mentioned. Can you please let me know the exact steps I need to do in order to be able to change the sampling frequency of each sensor individually.

Thanks,

Shervin

Hi Shervin,
The V3 devices do NOT use delay values. it has a new parameter called an interval. it sends data after an interval which is a multiple of 5min.
We only recommend node red for setting v3 sensors. These sensors have over 50 parameter settings and its not possible to set all using a micro gateway.
@TravisE_NCD_Technica what if someone flashed mega modem firmware into the mico gateway ?
can it be used with node red ?

Yes, if Mega Modem firmware is flashed into a Micro gateway such as the AWS or MQTT Gateways then it may be connected to the computer via USB and connected through Node-Red.

Documentation on flashing firmware to the Gateway can be found here:

Thank you for your reply,

I wanted to verify something. After holing the config button on the sensors and than modifying the delay few times. It actually started to send MQTT messages on AWS test client every 2 seconds for the “AC Current Monitor”. Did I ruin anything on the sensor for doing this? Two things I did was click the reset button on sensor and than click and hold the config button on sensor for 6 second. Then sensor appeared on the bottom of UI and after clicking the config I changed the delay and clicked saved. I did this procedure a few times with different delay values and suddenly on one instance it worked and it was sending messages rapidly. Just want to make sure I did not ruin anything. How would I reset it back to factory default?

Also I have few more questions

  1. So what devices are considered v3 devices?

  2. Can we just use v2 devices instead? We want to be able to change the sampling rate via AWS “Micro Gateway” initial setup. This seems the easiest option without needing to install anything. Just as part of the steps of setting up internet access and AWS access we can set this

3.Also all the v3 sensors work out of box with the AWS “Micro Gateway” right? Only issue is setting the delay correct? The reason I say that it because I noticed on the messages on AWS MQTT test client had the same exact values for the “Predictive Maintenance Sensor Plus”. Even though I was shaking the vibration sensor

  1. Can you please clearly what I’m expecting on AWS MQTT topics. Or point me to the documentations for the expected payloads on AWS MQTT topics. What I have noticed is I get the following on the interval"

a. I get a “update/documents” topic that contains the prev and current states. Each state contain records for for each sensors that has been turned on (node)

b. I also get “update/accepted” with a single sensor (node)

c. I also get a “shadow/update”

  1. You said the interval is in multiples of 5 mins. Does that mean it cant be below 5 mins?

Thanks,

Shervin

Hi Shervin,
Your current sensor is fine.

  1. the devices which have base SKU PR55-61X are V3. You can find that in the product name as well.
  2. V2 devices are not recommended anymore. V3 is far superior in terms of functionality.
  3. Yes, they will work out of the box with the gateway. You will need to install on a vibration machine to test. like a washing machine if you are testing at home.
  4. @TravisE_NCD_Technica can you comment?
  5. correct. Vibration does not change that quick.

Thanks

It sounds like you have your AWS Gateway configured to report telemetry to the Shadow Document on AWS IoT. The user guide for the AWS gateway goes into more detail. However you can also enter a topic format in the AWS gateway to publish the data to an MQTT Topic if you prefer that. You will see a field in the AWS Gateway to change the topic.

Thanks for reply,

So the “AC Current Monitor” is a V2 device. Does this mean it can set to sample every 2 seconds?

If so can you send me the instructions on how to set the sampling frequency for this sensor? I still cant seem to be able to set it using the Amazon AWS Micro Gateway. I have tried to change the delay under the “Devices” section

Thanks,

Shervin

99% of devices are V2. Sensors which has vibration ( only 3 products ) are V3.
Sampling frequency if which sensor?

“AC Current Monitor”. How do I set the sampling rate? Can you please send the instructions? Can it be done using the Micro Gateway for Amazon AWS?

the sampling interval is the delay value. i thought you already set that and the current sensor was sending data after every few seconds.

Yes after few times trying suddenly it started to work. But I cannot reproduce it consistently. That’s why I asked for the step by step guide. to make sure I’m doing it correctly.

aha i see
this is how you put the sensor in cfg mode

  1. press and release the reset button
  2. immediately press and hold cfg button
  3. keep cfg button holding for 6-7 sec
  4. release cfg button

this will put the sensor in cfg mode

Thanks

Thanks for this,

But can you please give me the steps using the AWS Micro Gateway. These are the steps I have been following AND I cannot consistently get it set

1.I hold the red button for few seconds inside the AWS Micro Gateway. Then a WIFI named " WiFi_Micro_Gateway". I click and connect to it

  1. Once connected I navigate to tab called “Devices” and I click the button named “Switch to Configuration Mode” on the bottom left of screen as shown by screen shot named 1.png

  2. Than I click reset and click and hold config button inside the “AC Current Monitor” sensor and than after few seconds the sensor shows up in the screen. Then I click the “Configure” under the “Settings” column as shown in screen shot name 3.png

  3. After that I change the delay to 10 seconds and I navigate to other tab and click “Save Settings” button as shown in screen shot named 4.png

But after I do not see the sensor sending telemetry messages on AWS every 10 seconds. Not sure what step I did in one of the times I was changing it that got it to work. I just need to be able to reproduce it every time so I can hand off the instructions to field technicians that are going to install the sensors in a few weeks.

Thanks again for your time



@TravisE_NCD_Technica do you have any video sensor cfg using micro gateway?

@Anil_Bhaskar no, I don’t have a video but there are detailed step by step instructions here:

The error in your steps @alayarda is that you are putting the gateway into configuration mode too soon.

Prior to putting the gateway into configuration mode you should press the RST button in the sensor so it appears in the list, then edit settings as desired, then switch the gateway to config mode, then put sensor into config mode.

Yes that works. Thank you

1 Like

One more thing I wanted to verify. I know we can modify the topic format to send to specific topic on AWS. But would it be possible to format the topic payload? So I wanted to have a same topic message for two different sensors. For example one attribute would be sensor name and one attribute would be value.

Thanks

Hi,

We do not currently support formatting of the payload. This would require some firmware development to implement. To this point we have not had a request to format the payload as this can typically be accomplished on the server/cloud side.

Today we got 4 new gateways (Version 1.0.9) and I was trying to configure them and the UI looks a lot different than documentation that is provided on your website (https://ncd.io/wifi-micro-gateway-setup-for-aws/)

I cant find anywhere to put AWS access key and secret. I have tried to set the client username and password but it did not work (gatewaySetup3.png) I keep getting red flashing light on the gateway. So I was not able to see the payload received on AWS. Can you please send the documentation for setting these keys so I can get the message on AWS?

Also how do I configure the topic I was it send too on AWS?

I know you said we cannot modify the payload but on these gateways there are some attributes where I think it can achieve some of the things I’m trying to do. As you can see from screenshot I have provided (gatewaySetup3.png) there are 4 attributes which I think can be used to modify the format. There are gateway message and topic format. Also sensor message and topic format fields. Can I get a documentation of how to fill these in?

We are trying to send these to our client as soon as possible so they can be installed on mining equipment so can you please provide some help so we can do this as soon as possible. I noticed the gateway connector which I did all my testing last week was version 2.0.6. So the 4 connectors we got today are actually older ones (Version 1.0.9).

Thanks,

Shervin


Hi Shervin,

The UI you are seeing is for an MQTT Gateway, not an AWS gateway, that is why you are not seeing fields for IAM credentials.

What is the online order number these gateways were ordered under?

Regardless you can re-flash these gateways with AWS gateway firmware. Instructions for doing this can be found here:

Thank you,
Travis Elliott