MIRPRO MP44-20_SET not transmitting

We are not getting voltage or current out of the transmitter. We are powering the receiver (sender) signal with a 789 Fluke meter and receiving the signal (transmitter) with another 789 meter reads the signal. We are not getting any mA signal out. We are getting the signal out to the transmitter and can view it changing on the config page with 5 blink status.

Any ideas?

I think I’m trying to figure out the same thing. Is jpugh 's test setup in the picture correct? It makes sense that the Receiver “sender”, Input 1, should be connected to the input signal, that is then mirrored to the Transmitter, Output 1.

Is the picture missing loop power for the output? Assuming the control voltage in the picture is 24VDC, would the connections be correct if Transmitter Output 1 (+) was connected to +24VDC, then the meter positive lead was connected to Transmitter Output 1 (-), and the meter negative lead was connected to -24VDC ?

Fundamentally the wiring scheme shown in the photo is correct. However it is important to keep in mind that the MirPro 4-20 input board(the one on the left) is a loop powered input which means it is providing loop voltage to the 4-20mA circuit so if the Fluke meter is providing loop voltage that would not work. The 4-20 mA output MirPro device(one on the right) does not provide loop voltage so that Fluke meter would need to generate the loop voltage.
This is the most common wiring issue with 4-20mA devices.

I tried to ask a pretty clear question about how to wire the transmitter output. Can I get a response to that?

I will answer my own question. This works: Transmitter Output 1 (+) connected to +24VDC, and the meter positive lead connected to Transmitter Output 1 (-), meter negative lead was connected to -24VDC.

If your background is typical industrial 4-20 mA I-O, then you might expect the Receiver input to provide loop power (it does), or require loop power (it does not).

You would not expect for the Transmitter output to require loop power (it does). Because industrial digital multi meters are not set up to provide loop power when checking a 4-20 mA signal, this requires extra wiring right away to test what is going on.

Once you figure out the difference, the MP44-20 is straightforward to use.


My photo fluke connections were incorrect. The sensor side (left meter, receiver) is correct. The PLC side (transmitter) is incorrect. the probes should be on source - probes all the way to the left socket to that the meter sends or sources current straight to the receiver.

In my opinion, the nomenclature is convoluted and confusing with few examples to go by. This is should not be that difficult and of all the instrumentation we use, this is by far the least clear. I don’t understand why they call the “sender” also the “receiver”.

There is an ongoing internal battle here about which of these device should be called the transmitter and which should be called the transmitter. It is common to call a device that outputs a 4-20mA signal a 4-20mA transmitter and the input that connects to a 4-20mA receiver. However these are wireless devices so it makes sense to call the input board the transmitter since it is transmitting the 4-20mA signal to a wireless receiver which is generating the 4-20mA output.

Believe me I am as confused by the labeling as anyone but it’s just the way it is for now until I win the battle.

1 Like

I agree! The only thing that saves the naming is one radio’s terminals are labeled “Inputs” and the other radio’s terminals are labeled “Outputs”.

Another question: how did you put the radio in configuration mode? I need to change the Transmit Interval, but I do not find the “Config mode button on the side of the enclosure” that the documentation talks about.


@TravisE_NCD_Technica can you provide any tips on how to find the config mode button?

Push the config button on the RH side via hole in the case.

After the blue status LED illuminates on the front, go to WIFI settings on your phone and select “Mirror_Sender” or “Mirror _Receiver”.

It opens a small sign-in page (no password) with all of your MirPro device info - MAC, channel info, calibration table, etc (be patient, it takes a few moments to load).

It will automatically reset if you modify and save any settings. Alternatively, you can cycle the power or push the config button again to escape this mode.

You don’t really need to access these settings but you should connect once to see how it works and check the calibration. It will give you live analog readings on BOTH devices in this mode (if you connect to each device using two phones). I have never used a PC to do this but it is theoretically possible.

Is the hole in the case labeled? If the antenna connector is on top, is the config hole located somewhere among the aluminum fins on the side? Next to the input connector? I’m not seeing it…

Thanks for the phone screen shots.

@richard.vaughn it sounds like they may have missed the hole that is suppose to be on the side of the enclosure. I’ve seen that happen a couple of times now. Production is still getting use to this new product line.

Remove the screws on the end of the board where the antenna connects. Then grab by the antenna connector and slide that board out. You will find a button on the side. Connect power, then press that button and the LED will begin flashing Blue. It is now in Config mode.

I will bring this issue to Production’s attention.

Holy cats, how did they forget to drill the configuration access hole?! Sounds like QC was asleep at the wheel.

Pull the guts out and drill a 6mm/1/4" hole in the side of the case 35mm from the back and 17mm from the top. There should be a tactile switch you can access.

The holes on ours are off by 4mm so I modified the dimension for you.

No, not labeled. Have you pulled the electronics out of the case? You will see the button when you do that. Yes, you will have to drill the hole in the fins.

post a picture of your transmitter

I pulled it out of the case, and the WEB UI going. Now I’m stuck on trying to change the Transmit Interval. I can change the value in the box on the interface, but after the unit bounces out of config mode, and I connect again, the value is back to zero.

Save button is out of view at the bottom - modify the number and scroll down to the save button, only hit it once. Another bug or it will not save the value.

Save button is in view on my phone, so no issue there. I have tried a number of times, careful to only hit “Save” once, but it could be bouncing? I am going to try a different phone, to see if that makes a difference.

If your MP44-20 Transmitter is still on your bench, are you able to change the Transmit Interval? I am curious if the issue I am having is only on this device.

I just changed it from 3000 to 4000mS and it worked. We had a problem where the TX didn’t like smaller numbers than about 3000 (or some small number, I cant remember exactly). We had to set it to 9000mS. Try that as a test.

Okay, what about the Change Threshold? That’s the value I was really after. I can change it, but it doesn’t stay changed.