MIRPRO MP44-20_SET not transmitting

Mine is set to 0, the default value. I just tried to set it and it worked although 700mV went to 0.9261V, possibly the minimum digital equivalent. But is was adjustable.

Just to verify, you put it back in config mode when making changes right?

Okay, you’re on to something. Travis said the value was in mA, so I was trying values like “5.0”.

I entered “2700” mV, and that got converted to 5.00 mA. I will try testing it now. Thank You!

Sweet! Hope it works.

We developed a 0-10VDC version of this product. I am wondering if somehow conversion values for that project leaked over to the 4-20mA version.

I can tell you that the value entered is divided by 0.00063 and that is what is used for evaluation. Essentially the value is converted to a 16bit ADC value and that is how it is evaluated.

Non the less this is not intuitive so I’ll see if I can get it corrected in firmware.

Okay, I used 5700 mV, and that gets converted to 10.5 mA. So enter 5700 in Change Threshold, “Save Settings”, re-connect, and “10.5” is displayed.

What did trip me up is that I shortened the Change Interval, but left “10.5” in the Change Threshold. When I hit “Save Settings”, that had the effect of changing Change Threshold to a near zero value.

So what needs to happen is to enter the Change Interval (in this case 5700) each time the Change Interval is modified, so the number is converted to mA. If this doesn’t make sense just give it a try, paying attention to both Change Interval and Change Treshold values.

Thanks again, @jpugh I wouldn’t be nearly this far if you hadn’t jumped in and offered advice.

Glad that worked, I learned something as well.