Megamodem MQTT - help with Configuration changes to PR55-5A

I have read the PR55-5A manual, but it isn’t clear to me how I can configure it via my Megamodem connected to my MQTT server. I do not have LabView, because it isn’t available for my OS (linux)

The Megamodem is subscribed to the “Megasub” topic, but when I put the PR55-5A into configuration mode by holding down the “C” button for 2 seconds on startup, and send “junk” to the Megasub topic, I don’t even get an error produced.

Do I have to specify every single option? Or is there a way to only specify the option I’d like to change?

Would it be possible for someone to send me a sample MQTT message that would change the frequency which the PR-55A sends data to send more frequently? Every 10 seconds for example.

Here is an example of what my Megamodem is publishing from my sensor on my MQTT server. I’m measuring water level with a 4-20ma sensor.
Megapub {“data”:[126,0,25,144,0,19,162,0,65,244,61,133,255,254,194,127,0,3,3,232,10,0,45,0,27,102,1,226,252]}


With the hardware/software configuration you have currently you do not have a method to configure settings in the sensor.

Given the hardware you have you would need to connect the Mega Modem to a windows computer in order to configure settings.

Alternatively you could install Node-Red on your Linux Computer, then connect the modem to the Linux Computer via USB. Then you could configure settings into the sensor as explained in this video tutorial:


I followed the instructions in the video but I can’t seem to change the node ID or the reporting period. Can you recommend how to troubleshoot?

Are you seeing any error messages in the debug section when node-red attempts to configure?

Does your wireless gateway say that it’s ready or in config mode?

Do any LEDs light up when you are holding the configuration button on the sensor?

When I initially reported this, I was not seeing any error messages and everything worked exactly like the video except I could not change the node ID or the reporting period. However, now I am seeing:

TypeError: Cannot read properties of undefined (reading ‘on’).

I’ve set up the gateway to use Serial Device /dev/ttyS3 (115200), and I’ve set up the sensor to use the same for Serial Device and Serial Device for Config.


This error usually indicates a duplicate serial port being used by the config-nodes. You can check for duplicate under the menu in the top right (three horizontal lines) > Configuration nodes > ncd-gateway-config.

If you only have one wireless module connected to Node-Red you should only have one of these configs.

Thank you. I deleted the duplicate serial port (was named “Onboard Wireless” but also pointed to /dev/ttyS3).

However, now under the gateway it says “Connecting…” with a green square next to it, there is no status under the sensor, and I see no debug messages.

The sensor LED still lights up red when I press the configuration button.

Not sure if it’s clear from my last post, but I’m stuck here - any suggestions?

You can check to see if deleting the superfluous config left your other nodes not having a communication node attached.

If that is not the case you can restart node-red and power cycle the attached modem to make sure the serial port isn’t stuck open on either side.

I’ve power cycled the modem and the sensor and the situation remains the same.

How do I check to see if deleting the superfluous config left my other node not having a communication node attached?

They will have a Red triangle in the upper right of the node that if hovered over will say Invalid Properties: - connection

Did you also restart node-red?

There’s no red triangle.

I did not restart node-red - how do I do that?

I have ssh enabled and I haven’t changed the default password (which I use to log into the gateway via the web page), but it keeps rejecting it when I try to log in via the command line. I’ve been seeing ways to restart node-red from the command line, but since this ssh login is failing I’m hoping to either fix this login issue or restart node-red another way.

The most straightforward way to restart node-red is to just power cycle the gateway provided you’re using on of our gateways.

The SSH instructions will vary depending on what exact gateway you have.

If you’re still having issues after a reboot you’ll have to let me know what gateway you’re using and if the Mega Modem mentioned at the beginning of this topic is still being used.

I am using the Enterprise IIoT Gateway (from Robustel):

For some reason, after a long time SSH accepted the password, but after power cycling again SSH is not accepting the password.

We bought another system with the same components and didn’t have any of these problems.

Is it possible to do a screen share to debug? We are blocked on acquiring more systems until we figure this out.

The Enterprise Gateway will only allow an SSH connection through the ETH1 port (direct connection to PC) unless you open the firewall to allow it over WiFi or ETH0. To open the firewall you can go to the web interface of the gateway and then on the left choose Network > WAN > ETH0 and click the edit icon. Change the firewall zone to internal.

Additionally the serial port used to talk to the onboard wireless module is /dev/ttymxc2

We can do a screenshare let me know you availability and I will send you an invite. I am generally available for calls between 10AM and 4PM Central Time.

Hi Jacob,

I made the change to the firewall zone, but SSH is still not working (password continues to be rejected).

/dev/ttymxc2 does not show up as a configuration option in the list of Serial Devices within the node-red webpage. Also, we used the settings in the video (/dev/ttyS3) on our first system (with the same components) and it worked fine. It’s just that this new system is giving us trouble.

I am available for a screenshare session at 2 pm CT. Looking forward to chatting.

Hi Jacob,

Any luck testing with internal units on your side to figure out why we can’t change the node ID and reporting period?

@jacob can you take a look at this when you get a chance


Testing is not showing an issue setting the Node ID and delay of the 1-channel current sensor. Can you check that the antennae on your sensor and gateway are securely seated and try again?

Are there any other modems or gateways in the area that would also be in configuration mode? This would be unusual, but it can interfere.

Can you try to move the sensor to the same room ~2 feet from the sensor to see if you can set it at this point?