Enterprise IIoT Gateway - Wireless module did not respond

Hello

I have a bug using Enterprise IIoT Gateway, I have some Predictive Maintenance Sensors, the communication of these sensors fails very often, sometimes the sensors do not communicate or stay in FLY state, I have tried to Restart Node-Red but it does not work.

image

Using Node-Red with @ncd-io/node-red-enterprise-sensors, the pre-installed library, sometimes I get an error from the Wireless Gateway node, this is the error:

{"code":1, "description": "Wireless module is not responding"}

Also, I read from Node-Red the /dev folder to find the ttymxc files, which is the dev to use the default wireless gateway on the IIoT Gateway and sometimes it just reads:

/dev/ttymxc0
/dev/ttymxc1
/dev/ttymxc3

or sometimes it can’t read the /dev/ttymxc0 file.

What can cause this error?

Translated with DeepL.com (free version)

Hi,

Can I ask for some more information?

  1. What wireless module are you using in the Gateway and sensors(2.4ghz, 868 MHz, or 900 MHz)?
  2. Could you provide your online order number so I can see the exact hardware you are working with?
  3. What Mode do you have the sensors set to? Processed, Raw, or Raw on demand?

Thank you,
Travis

Additionally I would check the Configuration nodes menu to ensure you don’t have duplicate communication interfaces configured. Commonly caused by Importing flows.

Check the menu in the top right (three horizontal lines) > Configuration Nodes > ncd-gateway-config. You should only have one serial port going to /dev/ttymxc2

Hi, @TravisE_NCD_Technica, @jacob

  1. Both gateway and sensors are 900 MHz
  2. The order number is 538187
  3. The sensors are in the Processed mode

This is my Config Nodes menu

image

And the config node of the Wireless Gateway node

image

Everything looks correct to me. I would try deleting the Wireless Gateway and sensor nodes, then also the ncd-gateway-config node and try creating them again. You can reference your screen shot here to setup the new Wireless Gateway node.

For what it’s worth these Enterprise Gateways have been very reliable and I have not seen the Wireless Gateway nodes ever fail to connect.

Thank you,
Travis

If there have been a lot of deployments and changes to the flow you might just want to try restarting node-red.

You can use an inject node into an exec node that uses the command:
pm2 restart all

That will restart node-red flush out all comms in memory.

Also the node red will say “FLY” till sensor sends its next packet and the next packet will come after every 5, 10 or 15 min based on the set interval values.

Hi, @jacob, @TravisE_NCD_Technica and @Anil_Bhaskar
I’m here again

I see this node state behavior. In the first tests, I saw that the sensor went to “FLY” state, 5 minutes later, it went to “Running” state, but now they only stay in “FLY” state, this tells me that the sensors can communicate with the Gateway, but only for one time and the Gateway does not receive more data.

This can happen to me with one sensor but there are other sensors that do have the normal behavior and the Gateway receives data correctly.

This is the graph of one sensor:

I run the command “pm2 restart all” from Node-red but I keep seeing the error “Wireless module did not respond” from the Wireless Gateway node over and over again

in this sensor do you have OTF configured?
whats the data transmission interval value set to.
whats the delay and node id set to

Yes, I have the OTF configured
The sensors send data every 5 minutes, which is how I have configured it.
The IDs start at 1, and the delay is 300 on each sensor.

set delay 0 and set interval to 5min

Hi

I have finally tried it, but the behavior is still the same.

This past week we tried connecting an ethernet modem to the Enterprise Gateway and disabling in Node-RED the built-in modem and all sensors communicate perfectly without losing data.

Testing with the Enterprise’s built-in modem some sensors do not communicate at all while others do communicate correctly.

I’m going to share with you all the sensor configuration, maybe that will help.

If the config option is disabled, it means that it never has never been configured, so the sensor hasthe default value.

Let me know if you have some time for a call and we can schedule a zoom call.

Hi, @Anil_Bhaskar

Sorry for late reply, hard couple of weeks

I have a scheduled visit where the sensors are installed this Thursday morning, would it be posible to have a meetting to look at this problem?

Please let me know what time would work for you.

sure you we can meet over zoom.

Yeah, sure, my email is dmunoz@bjgingenieros.com, if you need it

Hi, @Anil_Bhaskar
I’m really sorry, can we move the meeting to tomorrow, early morning, maybe 8:30 am or 9:00 am (GTM-6), if it works for you?

If not, we can move it to another day

Again, sorry for the inconvenience