Contact Closure Email Generator

We have a generator that we are trying to configure to send emails. We have not been able to send emails from the device. We have tried smart hosts of, and We did some general tests with PowerShell using the credentials for the office365 relay and had success. Any ideas on what our issue could be here?

When using Gmail it is required to enable Less Secure App Access under Security. You can find this by clicking Manage Your Google Account -> Security -> scroll down until you see Less Secure App Access -> switch it on.

The mail server address for gmail is

Please let me know if you have any other questions.

Thank you,
Travis Elliott


Thanks for the reply! We made sure to enable that before testing. Our main issue is getting O365 to work as that is the end goal. Any suggestions there?



I just tested on Outlook again and it does not appear to work anymore. They must have changed some security requirements. I will look into a fix for this. Can you use Gmail in the mean time?


We unfortunately do not want to use Gmail in the mean time. Just to clarify, we are trying to use the O365 SMTP relay ( and not Outlook. Is there any way to set SSL/TLS settings on this device? Are we also possibly running into a firmware issue? Do you have any documentation on upgrading the firmware if so? These are brand new devices so we assumed the firmware was pretty close to being up to date (Obviously we account for a slightly outdated version due to the devices sitting on a shelf for months more than likely).


Hi Nate,

There have been no firmware updates since the release of the product. We have not found any bugs since release. The product is really very simple. If the Mail server allows basic auth for SMTP communications then the device logs in and sends basic SMTP requests to send an email. There is more than likely nothing wrong with the board or the firmware but rather a permissions issue on the Mail Server which is not within our control. Office 365 is not allowing your device to send emails via SMTP, that is the problem. This is going to be a settings/configuration issue on the Office 365 mail server that must be resolved.

Hi Nate,

I have been looking into this a bit and I was able to get the device to send emails with outlook. Change the server to also make sure the address is Let me know if that works. I also had to verify my account so check your outlook in box for a message asking you to verify the account.


Thanks for the reply. We have set up countless devices to send emails through Office 365 with no issues. At this point we have also tried Gmail (with allowing less secure apps on and with two different mailboxes), other hosted mail hosts without SSL/TLS even, and even an internal SMTP relay. We are seeing TCP synchronization packets re-transmitting repeatedly when trying to generate emails.


Hi Nate,

That is very strange. I’m able to connect the email generators to my email accounts no problem. Is there any way you can send a screen shot of your Email Client settings that are being put into the device? You can blur out any information you do not want visible here or you can send it to me in a private message. There has to be something with your settings that is causing a failure. What is the subject and body you are trying to send?

You can monitor errors out of the device by plugging into the USB port of the Email Generator and monitoring the data coming over that COM/Serial port. You may need to install this driver:

I’ve installed the USBUART drivers, but I’m unable to get a virtual COM port on my laptop to be used for debugging the box.

We’ve also tested using SMTP2go services, and it’s still not sending out emails using that service either. So far we’ve tried internal email relays, external relays, Gmail, O365, personal web hosts etc. Tested on ports 587,25,465, etc. with and without SSL/TLS connections, still no email delivery.

From my packet captures, we see the device joining the network, ACKing a DHCP address, resolving the SMTP DNS name, and attempting a TCP connection out. This is where it fails no matter what email provider we use, as the TCP connection simply re-transmits until failure.

I’ve removed all firewall filtering and inspection services, it’s allowing any/any outbound, and isn’t blocking the NCD devices network traffic.

Please see packetcapture screenshot here:


Would it be possible to take this to someone’s home and try it from there? I am wondering if there is some sort of port blocking happening on the network the device is connected to.

It is currently at my home. I just happen to be using business-class networking equipment. There should be no port blocking as I can successfully connect to port 25/587/etc. from my computer which is on the same network. Again, all filtering and firewall rules have been disabled.

I am currently testing an SMTP relay service from and can successfully relay an authenticated email over port 25 to the service via Telnet on my Windows 10 device on the same network that the NCD box is connected to.

I am now getting some traffic on both inside and outside by trying this email relay provider. However the connections are still resetting and the email never goes through with the NCD box.

NEW EDIT (As I can only make 3 replies to a thread in this community)

One final update in the hopes of helping the team, or anyone else that is unfortunate enough to have to configure one of these systems…

I created the most simplest, “basic” test case for this thing which is:

  1. I setup an internal mail server on the same network as the NCDbox.
  2. The internal mail server is accepting port 25 connections, with no authentication or encryption required.
  3. Tested email delivery to an internal mailbox with Putty over telnet.
  4. Assigned unauthenticated and authenticated connections from the NCDbox and attempted “start up” and “contact close” email sends to the internal mailbox.
  5. Sat back and watched only TCP re-transmissions on my packet capture from the NCDbox on the LAN.

The internal mail server saw no connection attempts, and no queued emails.

I don’t think this box works period. Unless I can be provided the settings to an SMTP email gateway that I can be shown works, I can only state that the NCD contact closure device certainly can connect to wifi… but thats about all it can do.

Did you try changing the email server address to earlier or is it still I’m honestly at a complete loss as to why the device is not working for you. You are more than welcome to return it for refund. I’m just not sure what else to try.

TravisE_NCD_Technica - I work with the gentlemen that have been commenting in this thread. We have fair number of these generators spec’d for jobs, with the potential for many more. I would like to speak to someone via telephone to see if we can duplicate your successful tests, or find a way to return all of the units we have purchased, and cancel the pending orders. Please provide a way for me to contact someone so that this can be worked out.

Hi Chris,
Travis is on vacation today… He will be back on Monday. we will try to get this resolved asap.


Am I able to contact you in some way?

sure… i can be reached at

We’ve had the same type of issue with a seperate system and found our internet service provider blocks port 25.

We switched it to port 26 and works well.

1 Like

@chrishoward251 do you have access to one of the Email Generator products and are you available for a phone call today?