AWS Microgateway and Thermocouple sensor

I am not able to add NCD thermocouple sensor PR52-2 to my WiFi AWS Microgateway. It failed to enter configuration mode and I tried to connect it with Alpha Station but response “Unable to connect with modem”


Can you provide photos of the sensor and the AWS Gateway with the lids removed?

@Anil_Bhaskar can you confirm the power jumper in the Sensor is in the on position?

@sajjadkhanms configuring sensor settings through the Micro Gateway is not possible with the 2.4ghz modules you purchased the devices with. This is why you get the Failed to enter config mode error. However the sensor should appear in the list if you power it on on press it’s RST button to force a transmission.

power jumper is set to use batteries

Ok, this means the sensor is powered on. Are you seeing any sensor data on AWS IoT Core when the LED is lit solid green and you press the RST button on the sensor?

Hi @TravisE_NCD_Technica , thanks for your swift reply!
Yes, as @Anil_Bhaskar mentioned, I confirmed the jumpers are set to use batteries.
Our industrial prototype project required the collection of liquid temperature using an IoT wireless sensor and the transfer of its values to the AWS cloud via mqtt in Node Red, and this information is to be retrieved by another Rasp Pi Controller that controls a few field devices of the production line.

Note: This AWS gateway had MQTT Gateway firmware in it. As advised, I flashed the AWS Gateway firmware into it.

Now kindly advise how to proceed to attain this objective!

NO I can’t see this sensor data when the LED is solid green in AWS. I tried the reset button on the sensor but got no response. I also tried connecting the AWS micro gateway to my PC via USB port UART cable using Alpha Station, but was unable to connect to the modem in order to view the sensor.

The AWS Gateway is not compatible with Alpha Station. You need to connect the AWS Gateway to AWS IoT Core, then look for data there.

Agreed! The AWS gateway is not compatible with Alpha Station, but why can’t I view the sensor through the AWS configuration page? Ok, advise a solution to attain the above-mentioned objective. If required, we can connect through onilne.

It looks like you have provisioned the device on AWS IoT Core and it is connected indicated though the Green LED.

Can you provide screen shots of the settings you have saved on the AWS Gateway?

Aws.docx (1.0 MB)

Hi TravisE_NCD_Technica any updates for my issue?

Dear TravisE_NCD_Technica, kindly support the troubleshooting issue related to the thermocouple sensor and AWS Microgateway. If not, we have no other choice but to return the items.

are you able to put the gateway in cfg mode ?

Yes, I can do that. Also, if possible, can we meet online via any platform and solve this issue?