Wifi temperature/humidity sensor dim light after firmware update

Hi, I’ve got a PR58-1_MQTT and configured it initially, but never was able to get it publish to my MQTT broker (always showing solid white light). So I thought maybe a firmware update might fix the issue and followed the instructions on https://ncd.io/wifi-mqtt-current-sensor-user-guide/ but now the light is very dim and I can’t connect to it at http://ncd-4df4.local/ nor does it show up in Wifi routers. I’ve tried holding down the CFG and RST buttons to attempt to get it back into configuration mode, but I’m stuck with this unresponsive and dim-lit device.

Could someone out there help? This is my first time doing this and am very frustrated!

Hi Rob,

Disconnect power, then press and hold the CFG button, then reconnect power and wait for the LED to turn blue, once the LED is blue release the CFG button. That should force it into configuration mode.

If you attempted to flash firmware please let me know which firmware option you flashed to the device.

Thank you,
Travis Elliott

Hi Travis, thanks for the reply. I’ve tried this with CFG button but it just stays on the dim, multicolor, weak pulse. I also tried RST button. Video at IMG_3034.mov - Google Drive

I used the firmware from GitHub - ncd-io/WiFi_MQTT_Current_Monitor_Firmware and added firmware.bin → firmware then pressed back once it hit 100% and then did spiffs.bin → filesystem. After that, things took a dark turn.

Does anyone have an idea? I feel like I followed the instructions step by step and am totally stuck.

Hi Rob,
In the post subject you mentioned that you have a temp humidity sensor, I am not sure why are you uploading the current sensor firmware in this unit.
I will recommend loading temp humidity sensor firmware.


Thank Anil, ah rats. Somehow I looked back at the wrong guide and thought it was the “current” firmware (as in date) not for a current sensor.

What do I do now that I have loaded the wrong firmware and can’t put the device back into configuration mode in order to access the /Update page to load the correct firmware?

Yes, you should be bale to reflash it

I’m sorry, how would I do that as I can’t connect to it via Wifi because I can’t get it into configuration mode?

@TravisE_NCD_Technica can you share the process?

Hi Rob,

You’ll need to flash over the USB interface since the wrong firmware is loaded into the device.

To do that you can follow the directions here:

Select firmware option 23.

Thanks y’all. Back in business. For anyone else who gets here, keep fiddling with pressing releasing the RST button when flashing firmware during the … and ____ sequence. It was timing out for about 20 tries until I got the timing just right.

1 Like