WIFI MQTT password not being saved or sent


During the configuration of the Contact closure push notification product, we saved the settings but the MQTT password is not saved or sent when trying to make a connection with our MQTT Broker.

2022-08-24 17:15:42.506131+00:00 [erro] <0.20159.5143> MQTT login failed for user ‘“xxx”’: no password provided

We even tried simple passwords like 123456 but to no success.

Any advice is appreciated!

Can you please provide screen shots of the configuration you are loading into the MQTT Push Notification?

Hi Travis,


It does save the settings, but once I reload the password field is empty again

What does the LED on the device do after you click Save Settings? Does it go back to flashing blue and re-enter setup mode or does it attempt to connect to the broker?

Would you be willing to send me a private message with the password for the MQTT Client so I can test connectivity using the credentials?

Hi Travis,

It connects to the wifi perfectly and afterward, starts blinking red. Then I got a log entry in the MQTT Broker that I tried to log in without a password.

Definitely! I’m not sure how I sent a private message tho.

Just click on my name in this thread. You should see a pop up where you can click message. I will try loading the exact same credentials into a device here to connect to your broker so include the Broker URL as well if .com is not the end of it(if cut off in screen shot).

I just used the MQTT.fx client to attempt connection to the broker using the credentials you provided. As you can see by the attached screen shot this was not successful so something is wrong with this configuration.

1 Like

Hi Travis,

Currently i am able to connect to the broker using client applications, but if I use the contact closure product it keeps saying in the logs of the broker that no password is provided:

2022-08-30 09:16:52.933160+00:00 [error] <0.9441.1> MQTT login failed for user ‘“sensor”’: no password provided


Did you manage to resolve this issue? I seem to have the same problem with an MQTT Temperature and Current sensor,