WiFi Micro Gateway MQTT not finding wifi network

I just got a the WiFi Micro Gateway MQTT gateway and am attempting to set it up. I am at my office and am trying to connect to my work wifi, but when i go to the page to configure it, I do not have the option to connect to that network.

When tuning turning a personal cell phone into a mobile hotspot (network N9T shown above), I can connect to it, but can’t find the ‘-Devices’, ‘-DEV’, or ‘-Guest’ networks. Has anybody experienced a similar problem and can offer some solutions?


In our Office we had trouble connecting to Hidden Networks. The MQTT MicroGateway refuses to connect if the network is hidden. The fact that they are showing in your screenshot, on your PC, might be because you have already connected to them, so Windows knows they are there.

Check if they are Hidden or not, that might help you narrow it down.

Otherwise, the only other things I can think of would be to make sure it is a 2.4Ghz network, and not a 5Ghz only network. I think the Particle board inside of these gateways is only 2.4Ghz capable, could be wrong.

1 Like

@kstokes suggestions are valid. Make sure the network broadcasts it’s SSID(Not hidden) and make sure it is a 2.4ghz capable network(not 5ghz only).

If you have confirmed all of this but the network still does not appear in the Network drop down list please let us know.

Thank you,
Travis Elliott

I’m having a similar issue with the mqtt gateway. I am trying to do some field testing using my iPhones hotspot, but cannot find it in the network list. I tried entering it as a hidden network but that didn’t work either. Any ideas?


Is the Gateway seeing other networks?

Have your verified the hotspot it broadcasting SSID in 2.4ghz frequency?

Turns out there is a “maximize compatibility” toggle in the hotspot settings, that enables the 2.4GHz Wi-Fi. I turned it on and was able to connect. Thank you.