Wifi AC Current Monitor AWS -- Message not sent to AWS IOT

HI all –
I have my device connected to wifi, and it registered itself with AWS IOT. I can see activity in the aws IOT monitor section (# of connections goes up and # of outgoing messages goes up) but I don’t get anything when I subscribe to the MQTT wildcard (#) messages. If I post a a test message thru the aws iot console I get the message instantly in the subscription to whatever topic I post to.

My device has a flashing green led which should indicate its sending properly. (Interval is set to 5000ms).
It did register the device properly with AWS IOT under “Things”. I even removed it and restarted my device and it reregistered itself with AWS IOT under “Things”. So I’m assuming the wifi and connectivity with AWS is all OK.

I turned on AWS IOT logging and don’t see any messages being logged to the topic in the MQTT console when I subscribe to # or Office/# etc.

I’ve followed the instructions here from start to finish, and changed the “Cloud Topic Format” to a few different things to see if that was the issue. I’ve tried the default in the instructions: Office/::Sensor_Type::/::Sensor_ID::
and I’ve also tried some simpler topics configurations like “Office/1” or “WellInfo”.

Any ideas of what I can do to see the messages at AWS IOT? Are they perhaps not being sent from my device properly?

Thanks for any help someone can give me.

Hi Greggory,

It sounds like the sensor is indeed properly connected to AWS IoT so no issues there.

To debug a little more open the box and locate the USB Micro connection on the board. Connect a USB cable there and connect it to your computer.
You may need to install this driver in order for it to properly mount to your computer as a Serial/Com port:

You’ll need a program to monitor the serial output. If you’re on a Mac or Linux computer you can use screen from the terminal. If you’re on a Windows computer then I’d recommend Comm Operator Pal available here:

Open the port to the sensor and make sure you are monitoring at a baud rate of 115200, also make sure you are monitoring TEXT data on the serial port monitoring software.

Let me know what you see.

I think I got it hooked up. (Windows 10, x64, downloaded driver and used Comm Operator Pal Software as you indicated. installed driver and tool. Plugged in USB to device. I didn’t see anything to start with, but once as I was trying it I got the below message (or see image) when I restart the sensor while Its plugged into the computer. I’ve not been able to get the messages again though when I try it – its just been blank when I repeat the process.

Status:(11:45:28)Clear to Send (CTS) signal changed state. CTS State = True
Status:(11:45:28)Data Set Ready (DSR) signal changed state. DSR State = True
Status:(11:45:28)Clear to Send (CTS) signal changed state. CTS State = False
Status:(11:45:28)Data Set Ready (DSR) signal changed state. DSR State = False
Status:(11:45:28)Ring detected

I’m not sure of the timing of what to do first, but when I power up the sensor device, it ends up flashing green after a few seconds. I see in the AWS IOT Monitor page that it made a successful connection. Then when I turn on the monitor, it seems to not really do anything. Here’s a video of that process: https://www.youtube.com/watch?v=okv_Kak7ij4

It does seem to be recognizing the comm bridge:

What else can I try?

I just checked another sensor here with the same firmware and it’s working no problem. One thing occurred to me though. I’ll bet you’re in a different region. The region you set in the sensor needs to be the same as the region you are accessing in AWS IoT. Look in the top right corner of your browser window while in AWS IoT and you should see a drop down menu there to select the region. Mine for instance is Ohio so I make sure the device is set to that region and my browser is set to that region.

I just checked to make sure – It matches the US-WEST Oregon region. (Though the region is actually called US-WEST-2 by aws.)

I’ll try switching to Ohio to see if that makes a difference.

I’ve never tried Oregon before. Not sure if there would be any issue there ro not. Let me know what you find.
Also are you sure you setup the AWS IAM user correctly? It should have all permissions for AWS IoT. I honestly can’t think of anything else that would be an issue.

Trying Ohio yields the same thing. I changed the device to Ohio and then saw that Manage>Things got a new entry for the device. It shows connections, but I don’t see any messages when checking the MQTT client.

(Messages should be where the yellow highlight is right?)

Do you think the client Topic Format is set correctly?

IAM security at AWS:

And here’s the policy that is attached showing IOT Full Access.

Is there anything else I can try, or should I return it for another one?

I’m going to send you a private message with different AWS IAM credentials to try. Perhaps with this we can determine if the issue is the sensor itself or something with the account.