Unable to reconnect to sensor

We have a sensor that we have lost connection to and cannot reconnect. It was setup to operate on sleep mode (0) to relay other sensor data. Working great, except on this device power mode was still set to battery, so the batteries died. When switching power to external supply, the sensor did not come back online (like the others did). We tried the following:

  1. new batteries
  2. factory reset
  3. find device in config mode w/ xctu
  4. switch radio module w/ usb modem and check radio config values
  5. update firmware on radio module

Still, once reconnected, we are never able to find the radio-module. not with XCTU and not with Node-Red.

Hi Luke,

Can you provide a photo of the sensor with the lid removed?

Thank you,

Hi Luke,

There is a power switch right beside the battery holder on the main board. Currently it is set to use external power. Can you check if the sensor reports in when this switch is in the opposite position (closest to the enclosure wall). This will be the battery power position. If it works there it may be an issue with your external power supply.

If you’re not seeing any data coming from the device try hitting the red button on the board labeled C. You should see a status LED come on on the board. If you’re not seeing the LED you can try switching batteries

Hi Jacob,

I had already tried both those things. all the actions i mentioned before i tried from both battery power and external supply. external supply is also measured and providing 12v.

i do see the status led come on when hitting the C button.

Hi Luke,

That being the case, try this in Node-Red to see if you get even basic messages:

As a warning these steps will put your receiver into configuration mode. If you were unaware this will prevent any normal sensor data from being received until the gateway is taken out of configuration mode.

  1. Add a debug node directly after your Wireless Gateway node (add a wireless gateway node if you don’t have one)
  2. Deploy these changes
  3. Put the Wireless Gateway node into Configuration mode. There will be a button just to the left of the Wireless Gateway node.

You should end up with something like this image:
Screen Shot 2024-01-09 at 4.47.12 PM

Now on the sensor itself press the R button and release and then immediately hold down the C button for ~7 seconds. If held for more than 15 seconds it will revert to factory defaults which I would also recommend trying after this next step.

Once the C button is released check Node-Red’s debug pane to see if any messages came from the device. You should have received a PGM message within a few seconds. If not trying the factory reset by pressing R, releasing it, and then holding down the C button for 15 or more seconds. Once this is done you should receive a PUM message in Node-Red within a few seconds.

Success or failure be sure to take your Wireless Gateway node out of configuration mode to continue receiving sensor data.

Press power cycle the sensor to take it out of configuration mode and see if you receive data.

If all of that fails I would recommend taking the module from the sensor, putting it into the modem in place of the modem’s wireless module, running xctu and uploading our default sensor module profile through XCTU. Once the profile is uploaded put all modules in their original devices and see if sensor data comes through.

If not that’s about as much troubleshooting as can be done remotely and we can look at an RMA.

Hi Jacob,

aside from installing the default sensor module profile all the rest has been done without success. does this default sensor module profile just change the settings to the original settings on the device? because that too was already done with X-CTU.


that was done, still no luck. we will send device back for RMA. I have used another RTD transmitter to confirm. the radio is fine and transmits from the second case. vice versa the other good radio module does not transmit from first case.