Unable to connect to Base Station - ZADSR2410ProXR_ETHERNET

Hi, I recently purchased ZADSR2410ProXR_ETHERNET device and I connect to Windows PC with Static IP address - I tried to configure the Static IP address to the device but it doesn’t work - I tried both via the browser via default gateway - and via Base Software “LanX Etherent Setup”. Can you please help?


Can you try setting the static IP address by visiting the Ethernet module’s web page. You can enter it’s IP address into your browser.

So your PC has the static IP address of, what are you trying to set the ethernet module’s static IP address to and is there anything else using that IP address? You can check the MAC address shown in Base Station and the MAC address shown on the assigned port.

The device not being set to a static IP address when the router is told to assign it one is not really up to the device. The device simply requests an address when it is DHCP and the router should assign it the specified one.

If the ProXR board has the PGM/RUN jumper in the PGM position it will default the Ethernet module to DHCP.

Hi Jacob!

I do not know the IP address of the device and that’s the problem. I’m trying to identify it via Base Station software. I can see the device MAC address on top of the Ethernet port. So, without IP address, I do not understand which address I need to use in the browser. I tried the default gateway but it didn’t help.

I hereby attached the LanX Ethernet Setup window where I can see “Current IP address” as Is that the device IP static IP address I’m trying to set? When I hit the “configure device” button, I get an error message saying “Fail to connect device, check ip address”. So I’m confused now. What could be the reason. I can see the port and the board is functional with LED light indications.

The ProXR device is set to RUN mode in the jumper setting.

For DHCP, I can understand that the IP address is allocated by the router/server. But, regarding the Static IP address assgnment to this device, I’m really don’t know how to do that. Please help!

If Base Station didn’t find the device and you selected Lantronix Ethernet Configuration it will allow you to manually enter an IP address. That looks like what’s going on here so odds are there’s nothing at .1.150.

Does the device show up on any list of connected devices on the router?

Does it show up in the list of devices on Base Station if you power down the board, move the PGM/RUN jumper to PGM, and power the module up?

I think I identified the reason for the problem. I was trying to reach the device after configuring my PC IP address to static IP. Thats causing the problem. I tried changing the PC configuration to “obtain IP address automatically” and as per the IP address shown in Wireshark from the device, I can able to reach the device via the browser. Then I set the IP address as static and saved the configuration successfully. I believe the documentation has to be updated explicity stating not to set static IP in the PC side and which IP address we need to use to reach the device to configure it. Wireshark helped me this time to know the IP address of the device initially before configuring it as static.

Best regards!