Troubleshooting IoT Long Range Temperature and Humidity Sensors

Hi All,

Recently I got the opportunity to work with NCD’s Long range Temperature and Humidity Sensors and their Wireless USB Modem.
I want to setup a sensor network of 30 sensors in an indoors environment, so nothing too extreme I would say.

After initial configuration, however, I started running into problems. I had the sensors collect and log data (via node red) over the weekend, only to find out that after the weekend half of the sensors had stopped sending data. After inspection I learned that their batteries were drained. What most likely happened: I forgot to exit configuration mode.

After changing the batteries all is working fine for all but one sensor.

This sensor appears to be working (battery power is fine, LED lights up when pressing CFG). However, the sensor data doesn’t appear in Alpha Station, even after pressing RST on the sensor. Because it doesn’t show, I can’t access the settings and see what’s wrong. Entering/Exiting configuration mode doesn’t solve this problem, neither does a Factory reset of the sensor.

As far as troubleshooting goes I think I tried everything, but maybe I missed something. Anyone have any ideas on what might be wrong?

Maybe the radio module had a brownout and reset. This is rare, but I have seen this happen when any short-of-power glitch happens.
Here is how we can debug this
swap the radio module between good and bad sensors and see if the problem follows the bad sensor radio module. if it does I can share more on how to fix it.

Thanks foy the reply! I tried what you suggested, and indeed it follows the bad sensor radio module!

So, what can I do to fix it?

plug the bad radio module in the usb modem
and reflash the profile.

You will load the sensor profile ( check step 3)


I’m taking over for lznidarsic. I’ve tried uploading the profile using the gateway but the module is not recognised at all. Other modules are recognised.

I’ve got another sensor that is not working and I tried uploading to that but that gave met the following error:

Am I using the wrong profile?

are you using 900mhz radio or 2.4ghz ?
do you have a USB modem you can use to upload or check the radio firmware?


We are using 868mhz modules. I’ve got the gateway which I can use to check the radio firmware. How should I check that?

Check the how-to upload firmware guide. it explains how to use XCTU. Using xctu you can check the firmware.
feel free to share a screen shot of the settings.


I send this in the wrong topic. These sensors don’t get recognized when I put them in the gateway and use the XCTU tool. It seems like the zigbee modules have broken down. Other sensors do get recognized. How can I get them replaced under warranty?

no worries.
please fill out an RMA here and send the units back.
we will take care of it

Thank you for the reply.

The link you send me points to the login page. Can you send me the link for the form?

You will need to create an account.

I have an account but the link you send is “NCD Login -

you can login there using your id and password