The workspace contains some nodes that are not properly configured

Good morning! I have recently updated my node-red ncd nodes to the most recent versions and ended up getting a configuration error on some of my nodes. Before the update there were no errors. The nodes with errors are sending data however.

I have tried deleting the nodes with errors, copying a node without errors and changing the MAC address but still get the same error.

Hi Jeff,

When you hover over the red triangles, what error does it report?

This is usually caused by an old default configuration that is now outside of the range of allowed values.


Hi Jeff,

These errors can safely be ignored.

I am working on a fix so that new updates will not throw these errors unnecessarily.

I will let you know when it is ready.

1 Like

Hi Jeff,

Can you let me know what version of the library that you have?

ncd-red-com v 1.7.2
ncd-red-wireless v 1.6.5
node-red = 1.2.9

Hello! While I have you, what does the ‘FLY’ message mean? I’m guessing it relates to the new OTF config settings. However, it seems to appear randomly and the OTF box isn’t checked.

Hi Jeff,

I have updated the library to fix the property error you’re seeing. It will now set a default value if the property is undefined or blank.

The fly status you’re seeing does refer to the new OTF configurations. This status just means that a FLY config request was received, not that the gateway is attempting to configure the devices on the fly. It simply means the sensor checked in for configuration updates.

If OTF is enabled you will see an OTN status, a configuration status, and finally an OTF status indicating that configurations are ready to be made, are being made, and are finished respectively.

1 Like