[Solved] I2C and SI7021 does not show as connected

#1

Hello all,

Did a quick search didn’t find what I was looking for.

Raspberry Pi 3 Model B Rev 1.2
I2C connected and linked to SI7021h I have been trying to get this working, but it appears that it does not detect it…the SI7021 shows a power light and is connected. I just cannot get the PI to recognize that it is there…Any thoughts ?

 0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f

00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- – -- – -- – -- – -- – -- – -- – --
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – --

0 Likes

#2

hi,
try this code


thanks

0 Likes

#3

Traceback (most recent call last):
File “SI7021.py”, line 15, in
bus.write_byte(0x40, 0xF5)
IOError: [Errno 121] Remote I/O error

0 Likes

#4

looks like an hardware issue.
can you share a picture of your setup?

0 Likes

#5

Here you go.

0 Likes

#6

is it a pi3b+?
the small chip on the pi shield look damaged, is it?
anyways you can send it for a warranty repair/testing.


thanks

0 Likes

#7

does this not tell us what you are asking (sorry I am unsure how to tell) I do have SSH if needed. Also, I don’t see any damage on any chips. Just very dusty from sitting here for almost a year before I could get around to working with it. :slight_smile:

EDIT: Does this help ?
Hardware : BCM2835
Revision : a02082

0 Likes

#8

no problem. i think we will need it here in the office for further inspection.

Thanks

0 Likes

#9

uhhhhh, what do I have to do for that ?

0 Likes

#10

you will need to fill out a RMA

0 Likes

#11

Do you want the Pi as well ?

0 Likes

#12

no just the Pi shield and the snesor :slight_smile:

0 Likes

#13

heh, filling out RMA now. Thank you for all the help!

0 Likes