Solid red light on MQTT gateway

My MQTT gateway has not been working for me at all.

I’ve tried connecting it to my home wifi twice with DHCP and my laptop’s IP address as a broker - it doesn’t show up in the clients list. And after I do this and save the config, the LED right changes to solid red, which alternates to tri-color/dim. Sometimes it’s solid blue.

The documentation at doesn’t show solid red or solid blue. And at this point the configuration network has disappeared. I can ping the IP but can’t reach any kind of configuration page. What’s going on here?


Is your wifi network 2.4ghz? The gateway will not work with 5ghz wifi networks.

To put the gateway into configuration mode so you can connect to it over WiFi disconnect power from the Gateway, press and hold the CFG button on the Gateway, then reapply power. Continue to hold the CFG button until the LED begins flashing Blue. Now it will appear as a WiFi network you can connect to for configuration.

Also make sure you are not using a Microsoft browser when configuring the gateway as there are known issues with them. I recommend Google Chrome, Firefox, or Safari.

One last known issue is WiFi networks with passwords which contain special characters. Make sure your WiFi network password only contains alpha-numeric characters.

HI Travis, can you let me know what the other colors mean that aren’t in the documentation (ex. solid red?). I think I might be getting a little confused about switching back and forth between config mode - does the device always have to be powered on while the button is being pressed?

Also, if it can’t connect to the MQTT broker for various reasons (cant’ connect to WiFi, wrong password, wrong broker address, etc.) how do I debug that and what’s the expected behavior on the device?

Regarding the other questions - it’s 2.4ghz, chrome and there are no special characters in the wifi password. So I’m not sure why the device isn’t showing up under dhcp. If there’s some kind of log on the device that I could access it would be extremely helpful for debugging.

All Red status LEDs should flash. Solid red means the Gateway is “hung” in a process at some point. This could be an inability to connect to the WiFi network or an inability to connect to The MQTT Broker.

I recommended that you power off the device and hold the CFG button because it sounds like the gateway is getting locked up. The Gateway will check the CFG button right at power up and will switch to CFG mode is the button is pressed. This is why I recommended powering off the Gateway and holding the CFB button while powering it up.

I would recommend entering your MQTT Broker connection credentials in a software MQTT Client like MQTT.FX which you can download here:
If you can connect to your MQTT Broker using that client then the credenials are good, if not you may have an issue with The MQTT Client credentials.

Yes, I followed your instructions and I was able to reconfigure and now I’ve got a green light. I don’t have a password set up on my broker right now, which I’m just running on my personal laptop for testing.

The MQTT configuration says the topic “gateway/[gateway id]” should be sending some data, right? Is the ID the Mac or XBee address (I’m assuming that’s what’s on the side)?.. if there’s another ID that I should be using, where do I find it?

Honestly I think I’m missing some documentation. I couldn’t find much on the website for the MQTT gateway. I would hope that the various status lights, behavior, gateway id (is it the Mac, and is the Mac what’s printed on the side), how to pair a sensor, etc. would be defined somewhere. If you can point me in the right direction I’d appreciate it.


What are you using for an MQTT Broker on your computer? Mosquitto? I have an article here on Mosquitto setup you might take a look at:

The Gateway should send some information to that Gateway Topic but it won’t be the address printed on the side of the Gateway, that is the Gateway’s wireless address not it’s WiFi MAC address. Just subscribe to the wild card topic ‘#’ and you’ll get all publishes to The MQTT Broker.

If you’re interested I have another article here on logging data to a local MySQL database which is a follow up to the Mosquitto article:

I’ll take a look at The MQTT Setup guide and see if I can add more information on LED error codes.

Hi Travis, it’s Mosquitto. Thanks that works and I saw some data come through. How can I modify the sensor config to transmit more frequently?

You can configure the sensors using your gateway as explained in this article:

Thanks - I was able to get that configured. But can the delay be set below 1 minute? If not that might be a deal breaker for us. We’re looking for intervals like 5 to 10 seconds.

Also I can’t seem to get the device out of configuration mode now. Whenever I get the solid green light, it just goes back to flashing blue. The mqtt broker is working fine and the wifi network settings haven’t changed…


You can set the delay to 1 and the sensor will report as often as it can. Many sensors will report as often as 1 second but this does depend on the particular sensor you are using.

I do not know why the Gateway would switch to configuration mode after it is connected to The MQTT Broker. I have never seen that before.

Thanks, I was able to get it working. For some reason it looks like the config cleared out. Not sure if I pushed the cfg button down too long or what.