Setting up Sensors WITHOUT Windows

Has anyone worked with their NCD Devices WITHOUT a Windows Machine? I run a Mac. Seems silly to require a particular Computer OS to use IIoT sensors.

You don’t have to use Alpha Station. I don’t even have a Windows computer personally(I work on Mac primarily).

I would recommend using Node-Red installed on the computer with the Modem connected.

What Modem/Gateway and sensor(s) do you have?

Thank you,
Travis Elliott

Sweet! I have the Wireless USB Modem, Micro MQTT Gateway, and then a Proximity / Light Sensor and the 2 Channel Door Sensor

Travis -
I was able to get Noe Red running with my Wireless Modem, but the drop down to configure the wireless device doe not have ether of my sensors (2 Channel Door Sensor, Proximity / Light Sensor)
There IS a Proximity Sensor and a Light Sensor, but not one for the combo unit.

Is there some newer version of this command I need to run?
npm install ncd-red-wireless-2

device type two is 2 channel push notification and is valid for 2 channel Door sensor.
I will check the light proximity sensor.

@Anil_Bhaskar sensor type 9(proximity/light sensor) does appear to be supported by ncd-red-wireless-2. See line 1504 of the library here:

@rob.schoenthaler can you please provide a photo of the sensor with the lid removed as well as a photo of your modem with the lid removed?

Here you go!

The Proximity sensor in the list will give you proximity and lux values from the sensor.

Awesome, thanks, guys.

@TravisE_NCD_Technica @Anil_Bhaskar - I am having trouble getting Node Red to connect to my USB modem on my mac. Do you know what the format should be for “Serial Port” in MacOS?
the device is clearly connected and I can see it through System information, and I have the path for the serial Port from terminal:

What text should I put in the Serial Port field for the USB Wireless Modem in Node Red? I have tried all sorts of different option and it always fails to connect.


It should be /dev/tty.usbserial-AC8LAJSQ

Attaching a screencap.
Screen Shot 2023-09-01 at 1.01.55 PM

If that doesn’t work, you might check that nothing else is connected to that serial port such as XCTU or another software. Restart the computer if you’re unsure.

If you still don’t have connectivity it could be a permissions issue, if you’re an admin user its unlikely but worth looking into. Specifically you’d want to:
ls -al /dev/tty.usb*
check the owner and group
then run this command to see what groups your current user belongs to:
if you’re not a member of the group that owns the serial port you should add yourself to that group, generally this group is called wheel on mac for some reason. Other common name would be dialout

I just noticed in my screen capture I have a network ID of 7faf, ignore this part and don’t change from the default. It should be 7fff for your modem.

thanks, @jacob . So I am getting these errors (I did a full restart btw):
1 Sep 11:43:55 - [info] Server now running at
1 Sep 11:43:55 - [info] Starting flows
adding close handler now
1 Sep 11:43:55 - [info] Started flows
error: ‘Request timed out without response’,
original: [ 8, 1, 73, 68 ]
error: ‘Request timed out without response’,
original: [ 8, 2, 73, 68 ]
error: ‘Request timed out without response’,
original: [ 8, 3, 83, 76 ]
serial port is reconnecting
Error: Port is opening
at (/Users/Rob/.node-red/node_modules/@serialport/stream/lib/index.js:225:29)
at NcdSerial.setupSerial (/Users/Rob/.node-red/node_modules/ncd-red-comm/lib/NcdSerial.js:38:16)
at Timeout._onTimeout (/Users/Rob/.node-red/node_modules/ncd-red-comm/lib/NcdSerial.js:29:9)
at listOnTimeout (node:internal/timers:569:17)
at process.processTimers (node:internal/timers:512:7)
error: ‘Request timed out without response’,
original: [ 8, 4, 73, 68 ]

Let me know what time works for you and we can schedule a call.