Raspberry Pi Energy Monitoring Kit failing

Hi All,

I recently bought the Raspberry Pi Energy Monitoring Kit to test how it works before purchasing the larger devices for energy and sensor monitoring for my company.

After plugging in the equipment correctly (Power LED active on all boards) and booting it up on a Raspberry Pi 3 with Noobs. I installed the correct software for Cayenne and I was able to view the Pi online. But my problem comes from the energy monitoring module. I have grabbed a power board and passed the active wire through the coil on the board (tested and I can still power things with the power board I am using), the OLED screen does not display anything and Cayenne does not show any data (only the Pi status e.g. CPU, temp etc) or even has available widget to display energy monitoring. I tested having various equipment on the board to draw power like a kettle but no data is displayed.

On the Raspberry Pi, I ran a few test with scan feature and it found the attached board and OLED screen. I have tried updating the Pi drivers, tried to even add a picture to the OLED screen, tried different Raspberry Pi which all have failed to show any form of data.

Not too sure what else I can test, I bought this kit to hopefully see how it works and the site explains how quickly and easily it is to show energy monitoring but nothing been successful. Any advice or help would be greatly appreciated!