Question about Ozone Gas Sensor 12-Bit (MQ131 i2c)


#1

Hi @Bhaskar,

empierre/arduino/blob/master/AirQuality-Multiple_Gas_Sensor1_4.ino

I ran it with the code you gave me.
empierre / arduino / blob / master / AirQuality-Multiple_Gas_Sensor1_4.ino
A library error occurs.
If you have a library, please give it to me.

Arduino: 1.8.8 (Windows 10), Board: “Arduino / Genuino Uno”

sketch_mar05a: 175: 18: error: no matching function for call to ‘MySensor :: MySensor (int, int)’

In file included from C: \ Users ? 씠 낆꽑 낆꽑 \ Desktop \ sketch_mar05a \ sketch_mar05a.ino: 25: 0:

C: \ Users \ Duplicate \ Documents \ Arduino \ libraries \ MySensors / MySensor.h: 158:

MySensor (MyTransport & radio = * new MyTransportNRF24 (), MyHw & hw = * new MyHwDriver

^

C: \ Users \ Duplicate \ Documents \ Arduino \ libraries \ MySensors / MySensor.h: 158:

C: \ Users \ Django \ Documents \ Arduino \ libraries \ MySensors / MySensor.h: 149: 7: note: candidate: constexpr MySensor :: MySensor (const MySensor &

class MySensor

   ^

C: \ Users \ Duplicate \ Documents \ Arduino \ libraries \ MySensors / MySensor.h: 149: 7: note: candidate expects 1 argument, 2 provided

C: \ Users \ Django \ Documents \ Arduino \ libraries \ MySensors / MySensor.h: 149: 7: note: candidate: constexpr MySensor :: MySensor (MySensor &&)

C: \ Users \ Duplicate \ Documents \ Arduino \ libraries \ MySensors / MySensor.h: 149: 7: note: candidate expects 1 argument, 2 provided

exit status 1
no matching function for call to ‘MySensor :: MySensor (int, int)’


#2

hi,
you will need to place the .cpp and .h files in your arduino library folder.

Thanks


#3

I saved. The above error will still occur.


#4


#5

please can you post this issue on github lib as well. this lib was developed by a third party user.
You can look into this one as well

Thanks


#6

If I run the above code, I get the wrong value.
This is what I wrote.


So I tried to run it with your newly provided code.

However, the code below shows ‘MySensor :: MySensor (int, int)’.

empierre / arduino / blob / master / AirQuality-Multiple_Gas_Sensor1_4.ino


#7

in the picture it shows max 77ppm. when does it show 400ppm.
does the sensor reading change when you change the O3 value.

I dont have a sensor with me…i will get one and will give it a try. looks like there is data conversion issue.


#8
  1. 400PPM after 1 minute of operation.
  2. Sensor display before operation: 0.077ppm
  3. Sensor display after operation: 0.005ppm
  4. The ppm drops after operation.