Problems when factory restarting the IoT Edge Computer

Hello everyone!

I hope you are very well!!

I´m having problems when factory restarting the IoT Edge Computer, apparently it has problems downloading files from the manufacturer’s website.

I have tried:

  • Changing internet network.
  • Changing device to validate that it is not the device problem.
  • Testing on different days (I had this problem 2 days ago).

Reference photos:

Thank you.


I wonder if this is being caused by a network firewall blocking communication. Could you try on a different network?

Hello Travis!

Sorry for the delay. Yes, I tried with 3 different networks.


I attach a photo of when I try to update opkg with opkg update.


Does the network it is connected to have internet access?

Yes, in fact, I have tried with the network of the company where I work, the network with my home internet and the cellular network, all 3 are different internet providers.

To add, I have tried with 5 different GW.

That is very strange. For one reason or another the gateway is not able to communicate with the online package manager. What country are you in? US?

Is the Gateway connected to the network via Ethernet I assume?

We are located in Chile, I have been working with both Wifi and Ethernet.

It should be noted that this started about 15 days ago, I’ve set up about 60 IoT edge computers and haven’t had this issue.

I’m wondering if something changed on Onion’s side. I will reach out to them and get back with you.

Here is the response from the Onion team:

No changes on our end with the package repos.

They’re accessible online:

And opkg update is working as expected on a device I have at my desk:

Looking at the kernel messages from the customer’s screenshots, it suggests there’s something going on with the device’s file system:

To try to narrow down the issue further I would suggest learning about/doing the following:

  • We should understand how many devices is this happening on

  • Do other operations that use the file system work?

  • Since the customer mentioned they did a factory restore, we need to understand what’s going on with the device’s file system, please ask them to run df -h and post the output. You can then compare against a working device on your end.

  • To see if there’s issues with the overlay partition specifically, please ask them to run the following commands:

cd /root
gzip -d Packages.gz

They should then have a file name Packages that can be opened and is human readable with vi

If not, they should post the command line output

  • If the above doesn’t work, let’s find out if it works on the tmpfs partition by running:

cd /root
gzip -d Packages.gz

Again, they should then have a file name Packages that can be opened and is human readable with vi

Travis, as requested:


Another response from Onion support:

  • When they manually do the wget and gzip commands, have them try using vi to open the file and view the contents

  • For the “If the above doesn’t work, let’s find out if it works on the tmpfs partition by running:” step I had a typo in the command, it should actually be:

cd /tmp
gzip -d Packages.gz
vi Packages

Let us know what you see in the Packages file when inspecting with vi

Hi Travis!

I’m attaching a video since it doesn’t allow me to copy the text, if you look closely I still have the same connection problem.


Hello everyone!

Any news regarding this?

I can’t update Onion and with that, I can’t install some critical nodes for our project.

Thank you.