PR58-1_MQTT Temperature and Humidity Sensor with Ignition SCADA

Hi, I have a PR58-1_MQTT temperature and humidity senser that I am trying to get connected to Ignition. I can get the sensor to connect to my Wi-Fi but it does not want to connect to the broker. I have a red flashing LED which indicates this (it flashed red 3 times and keeps repeating this). I don’t see what setting I might have wrong. I can connect fine to Ignition using MQTT.fx when I test this. Any help is welcome.


What type of authentication does the Ignition MQTT broker require? Is it basic auth(username/password) or is it TLS(root cert, client cert, private key)?

Have you attempted to use the same credentials entered into the sensor in a desktop mqtt client such as MQTT Explorer just to ensure all credential, host, port, client ID, etc are correct? This is typically where I start if I have issues connecting an MQTT sensor. It’s simpler to troubleshoot on a computer.

Hi Travis,

Ignition is set to use basic authentication; TLS is not used.

If I understand you correct, then I did try to use the same credentials in a desktop app. In my case MQTT.fx. When I do that, I can connect fine to Ignition. Ignition is still set with the default username and password. What I did notice and find interesting is that when I set Ignition to ‘Enable Anonymous MQTT Connections (NOT RECOMMENDED)’ and I clear the username password on the sensor setup I can see that I get an extra client connection showing in Ignition ‘Connected Clients’ tag but the LED on the sensor still does the 3 red blinks, short pause, 3 red blinks, repeat. Not sure if that info helps you at all.

These is the basic setting in MQTT.fx and I entered the default username and password on the ‘User Credentials’ tab and this connects.

These are the basic connection settings on for the sensor with the same username and password.

Thanks for the help!


(post deleted by author)

​ ​ ​ ​

Hi, I am using basic authentication and not TLS. I have been able to get a connection to the Ignition broker because I see the LED blink green, and I see the ‘Connected Clients’ tag value go up in Ignition. However, I am only able to do this by allowing Anonymous MQTT Connections and then leaving the username and password blank on the sensor config screen. When I enter the username and password in these fields I can no longer connect to the broker. When I test the connection from MQTT.fx then I can connect using the username and password for the Ignition broker. I have tried this with the default Ignition username and password and a user I created, and they both behave the same.

Also, when I have the connection from the sensor to the Ignition broker, I still do not see any information come through when I subscribe in MQTT.fx (I do when I publish from MQTT.fx so I know the broker is working)

Is there any chance I have a defective module?

Apologies, there was a bug in the firmware pertaining to the password in basic auth. Please update as explained in the user guide here to v1.0.1:

Hi Travis, thanks for the info. I did the update and when I look at the status page (which btw doesn’t properly display but I can still read the text) says that the device is now on v1.0.1
It still doesn’t work though. I tried with two different user that I have setup on the broker and neither of them work. I get the red blinking LED. The only thing that is different is that I also get the red blinking LED when I leave the username and password for the broker empty. With the old version of the firmware, I would get a green blinking LED because I have Anonymous MQTT Connections. Again, I can still connect to the broker from MQTT.fx with both the user accounts. Could there still be something wrong with the firmware?

Hi Rob,

Are you certain you updated the firmware and the SPIFFS files during the update?

In your web browser can you right click on the password field, then inspect element and show me what you see there?

Thank you,

I did both and am pretty sure they went through since the device did a reboot afterwards. Not sure what all you want to know about what I see when I do the inspect so I have included a screenshot.

FYI, although the LED on the device blinks red I do see the ‘Connected Clients’ tag value in Ignition increase which is interesting. No data thou.

Why do you ask questions if you don’t respond to the answers? How can I return my sensor?

Apologies, I did not see your previous reply.

The screenshot you provided confirms the firmware and spiffs update was successful so you certainly have the latest firmware so Username/Password credentials will now work properly. This has been tested thoroughly by myself and several other customers.

The Red LED should blink a sequence to indicate the problem. Does it look like it’s flashing twice in sequence or 3 times in sequence? Twice indicates it cannot communicate with the temperature/humidity probe and 3 times in sequence indicates it cannot connect to the MQTT Broker. This may help indicate what the problem is.

Thank you,
Travis Elliott

Thanks for the response and the sequence info is useful. It does have the 2-blink sequence for the failed sensor connection, but it looks like everything is tightly connected.