PR55-61PM and MQTT Gateway

Hello good friends!

First of all, nice to meet you all, i’m new to this exciting world of IIOT and have been wanting to try NCD devices for a long long time. English is not my primary language so please bear with me.

Now, to the point, at my company we have been trying to find new solutions to add better monitoring to our equipments, we found NCD and almost became crazy looking at the miriad of options.

To begin testing if this could work for us we adquired the following devices:

  • PR55-17A (Wireless USB Modem)
  • PR55-21 MQTT (MQTT Micro Gateway)
  • PR55-61PM (Predictive Maintenance Sensor PLUS)
  • PR49-24E (Vibration Temperature Sensor)

So far we habe been able to pair the PR49-24E with the MQTT Gateway without trouble, read sensors data, send it to our MQTT Broker, do wathever we want with it.

Problem comes when trying go make the PR55-61PM work, Alpha Station seems to recognize it kinda… but the MQTT gateway is unable to find it, we have tried resetting it, getting the 61PM into config mode, changing node number, delay value, etc…

I have been reading some posts on the forum, it seems like the only way to configure this device is by using Node Red but i’m having some trouble installing it right now, i’ll keep trying.

Now, i think i may have made a mistake and the PR55-61PM is more like a stand-alone device, i can’t find anything on the product spec that says it can’t work with the MQTT Gateway.

I hope somebody can give me some hints.


@TravisE_NCD_Technica does MQTT supports sensor type 82 ?

Hi @ejcrashed welcome to the world of IIoT,

I just checked and type 82 should be supported. Just in case you got an old MQTT Gateway off the shelf from stock can you please try updating your Gateway to version 1.0.10 using the instructions here:

After update the web configuration page should show v1.0.10 at the bottom.

Let us know what you find.

Thank you,

Hello Anil and Travis! thanks for your answers.

OK, checking the config page on the micro gateway it displays 1.0.2.

I’m tryng to update it to 1.0.10 from Linux, so far no luck.

Following the instructions from the link Travis posted:

  • Python3: OK
  • pyserial: OK
  • Runing kernel 5.15, so driver is compiled in
  • Connect the gateway using USB, “CP2104 USB to UART Bridge Controller” detected, asigned to ttyUSB0
  • Had to alter Flash_Script slightly because it was omiting al ports starting with “tty”
  • Run script as root (if run as normal user cannot open serial port)
  • Script starts, downloads firmware files, tries to contact the gateway, leds flashing all colors, then fails

I tried pressing the reset button on the ESP when the …___… patern shows as recommended if flashing fails, but no luck.



Finally!, had to take the ESP32 daugterboard board out of the main board, with that the flashing worked!

Now the MQTT Gateway is able to find all the devices without problem!

Many thanks for all your help folks.

Great! You may be new to IIoT but you seem to be very competent and willing to do research :grinning:

Please let us know if you need anything else or run into any other questions.


Hello Travis, thanks for your help.

We will begin testing of the sensors next week on some of our equipment, so far they are sending data without a problem, but, we have discovered a posible bug in the way the MQTT GW is processing 32bit sensor payloads.

There are 2 sensor payloads which are sent in 32bit blocks: “thermocouple_temperature” and “current”, if we check these with NodeRed + USB Modem the values are okay, but on the MQTT Gateway the values are wrong, only these two.

For example, if I hold the thermocouple in my hand NodeRed shows 34.5, but the in the MQTT json it shows 0.13.

All other fields are showing identical values on NodeRed and MQTT Gateway.

Just for testing, flashed the MQTT Micro Gateway with the “dev” firmware but it seems like that one is older (1.0.2) than the latest stable (1.0.10).


Good to hear from you again.

It appears you have in fact found a bug. Currently the thermocouple and CT readings are being calculated as 24 bit integers when in fact they are supposed to be 32 bit integers. I will get this corrected and push a firmware update today. I will let you know when it is ready so you can update your MQTT Gateway firmware.

Thank you,

Hi Travis.

Amazing!, thanks for your quick response!.



I just pushed firmware update 1.0.11. Please update your firmware and let me know what you find.

Thank you,