NCD5500 Unable to obtain a DHCP address when connected to a Cisco Switch

When I connect a NCD5500 module to a Cisco switch (tried various models of switch) it does not acquire a DHCP IP address. If however a basic mini switch (T-Link) is installed between the device (NCD5500) and the Cisco switch it works fine. It’s almost like the DHCP request is made before the Cisco switch port is fully initiated and the NCD5500 does not make another DHCP request. It appears to only make a DHCP request on reboot???
I’ve tried changing all sorts of settings on the Cisco switch (portfast enabled, carried-delay etc, static duplex and speed settings). I’ve running out of ideas. Given that Cisco switches are widely used I can’t believe no one else has experienced the problem.

When connected to the Cisco Switch are you able to discover the NCD5500 module on the network using the NCD5500 Configuration tool linked in the user guide here:

If so I would attempt assigning a Static IP address to the device.

I used the NCD5500 Configuration tool and fixed the IP address. This seems to be the best solution in this case.