NCD-red-wireless-2 installation error

Having issues with the NCD library installation on Windows. Tried ncd-red-wireless-2 and @ncd-io/node-red-enterprise-sensors both not working.
Tried also on different node.js versions including 12, 14, 16 and 18.
I have also set ssl-strict to false.
Please help

I believe this is an issue with node-gyp.

Take a look at the windows instruction on the read me page here:

Also make sure to install the @ncd-io/node-red-enterprise-wireless library rather than ncd-red-wireless-2

I completed installation of visual studio and the node.js addon, installed node-gyp as well.

Still having same issues with @ncd-io/node-red-enterprise-sensors library, it seems there is no “enterprise-wireless” library.


@Jacob do you have any insight here? I do not have a lot of experience installing Node-Red packages on Windows.

It’s been a while, I believe you have everything in place as far as windows is concerned. It looks like your PC/npm/network does not trust’s ssl cert.

Does your PC give any warnings or errors when you open in a browser?
What version of windows are your running? Is it embedded or out of date?
Can you install any other packages from npm such as fft-js:

npm install fft-js

Node-Red recommends using the following command on windows to ensure the build tools are installed and correlated properly:

npm install --global --production windows-build-tools

You could try updating npm:

npm install -g npm

I do not get any warning or errors opening in a browser.
Running windows 11 pro (22H2) on a laptop.
No issues installing other packages
I have issues with the command npm install --global --production windows-build-tools
Updated npm but still could not install the ncd-io package


Unfortunately this is a difficult issue to diagnose even if I had full access to the PC and generally goes beyond the scope of what we can support.

It looks like the most straightforward path is to use the following command, but it is a big hit to security as it essentially disables checking for TLS certs in npm:

npm config set strict-ssl false

There’s a more secure solution out there that might work: angular - gyp ERR, Npm is unable to get local issuer certificate - Stack Overflow

As for the root cause, could be a corporate network overriding your trusted CA certs and node-gyp is trying to use the wrong one, could be a user permission issue if somethings was installed as admin, or it could be a firewall issue.