NCD Base will not connect to USB Modem

When I try to connect to the modem using NCD BAse software at 57600 baud. I get the window saying
the following
The controller did not respond to the baud rate you selected…

If I try the Digi XCTU software it will immediately connect to the modem. Any advice on this? I’m stuck at the moment. Is there any indication of the correct configuration for the Digi module API or AT mode for example?


The default baud rate of the USB modem is 115200, unless you changed the baud rate of the Digi module through X-CTU.

Also, keep in mind only one application can connect to the USB modem at a time since it mounts to the OS as a virtual COM port.

Thanks, no luck I’m afraid. I changed the baud rate in XCTU, the NCD Base goes on to try all other baud rates but then says it can’t communicate.


Hi Travis, I’m relearning things here after a 2 year break. Looking through some email chains, I found that two years ago that I had exactly the same problem and we never did manage to find out why the Base Station software wouldn’t connect to the modem. I’m going to try and get myself back up to speed regarding sending API commands to the relays.

Hi Tim,

Base Station is a very simple testing utility. It does not support API mode with the Digi module that well. If you have API enabled on the Modem then you should not use Base Station. You will want to develop your own application software for that.

If that’s the case(trying to use API mode). Use X-CTU Terminal to manually build a transmission packet to the remote board.

Something not jiving here, I’m apparently talking to the remote modem with XCTU because the light is flashing (on one of them at least) but no relay turning on or off. AT and API mode shown below