Ncd base not detecting r810pro

I ordered r810pro and also serial to usb converter , xchipi. When opened device manager all drivers are installed fine but ncd base does not recognize the relay board. Is there anything i missing here?

@Anil_Bhaskar Can you please check on this

There are 5 terminals that connect the relay board to the RSIO board. Two of those lines are GND. Use a short jumper wire to connect those two GND terminals together. This enables 2 way communication on the board so it responds to commands sent by Base Station.

If you are not connecting this board to a native RS 232 port on a PC then I recommend moving the on board PC/MAC jumper to the MAC position.

Thank you,
Travis Elliott

Thanks for the response Travis, i dont have the schematic for the RSIO board. what two terminals needs to be wired together and why is it not done by default?

I am not connecting to RS232 port on PC. I have Xchipi - RS232 to usb converter.

That information is available in the documentation here:

I tried connecting serial port directly to my another PC and it worked. It does not work when I use the RS-232 to usb converter(X-CHIPI-X). I installed all the required drivers and no issues in device manager. Is there anything else I need to setup. to make it work?


The default baud rate for the device should be 9600 if you do not move the baud rate jumpers.

Did you move the PC/MAC jumper to the MAC position? You may also switch the TTL jumper to see if that works.

Can you guide me how to do this, I am new to this. what do you mean by MAC here?
“Did you move the PC/MAC jumper to the MAC position?”

Can you please help me with this. This is delaying my work

If you look on the board you will see some black jumpers. One of them says PC on the left and MAC on the right. Move that jumper to the right by 1 pin.