Nbutton and 1 port pushnotification

at one point i had an ethernet one port push notification board working on N-Button-Lite. now that i am trying to recreate this again i am having a bunch of issues. when i am adding the device nbutton shows that it finds it and will auto ad it. I then try to add a widget (any of them) and nothing happens either it shows a big ? or the toggle does nothing to the board. any one have any ideas?


We actually did not design that software. I would recommend contacting the developer of N Button directly for support on that. Their site is www.serialporttool.com. They should be able to get you up and going quickly.

If you have any trouble at all with the Push Notification board hardware please let us know and we will be happy to assist.

Thank you,
Travis Elliott

Ok after much testing it seems i can not get the 1-channel to send any data when the contact are activated. ive tried all software on disc that you sent i can send data to it but i need it to work the other way aound

Can you open your web browser, enter the IP of the controller so you can access it’s web interface and send me screen shots of the settings you see there? I bet there is an issue in those settings somewhere. The module can be configured to send commands over TCP or UDP sockets but I bet it is not set correctly.

If you are prompted for a password when opening the web interface just press enter, password protection is not enabled by default.

I have tried TCP and UDP i have also used your recommended setting on your site but i have tried this with 2 devices so here are the screen shots.

anyone willing to help? these devices are not sending anything.

On UDP you need to check the Use Broadcast check box.

tried that still not working

do these devices have a specific firmware that they need to be running?

Ok. Open the web interface to the XPort module so you can configure it. I have screen shots here which show what your settings should be:

Connection Settings

Serial Settings

Once you have done this try N Button again. If it still does not work let me know.

I Wiresharked it and i can see it sending and receiving on port 3333 but NButton still will not work so i think the board is working.

In that case, I would highly recommend contacting the developer of N Button for support with their software. Just go to www.serialporttool.com and they should be Able to help you out.

I have there not very helpfull but thanks for your time

also do these need a special firmware? i upgraded mine and now it not quite right