MQTT Gateway - Unable to Connect


I just received my MQTT Micro Gateway and I am having trouble connecting to it.

I am using the setup guide and out of 20+ attempts I have only been able to connect to it twice and when I did it could not connect to the cloud based on the Ubidots setup guide (red blink LED)

When trying to reset the gateway to factory setup I have only been able to achieve rainbow twice, but I have been able to get it to return to blinking blue. I did notice two capacitors touching in the shown photo, but this may not have an effect.

Here is a list of things I have tried:

  • Restarting computer (3 times)
  • Forgetting network device
  • Resetting gateway to factory setup (multiple times)
  • Google chrome and Internet Explore
  • Removing power from gateway and restoring power

Am I doing something wrong by chance? Thank you.

New info: I have achieved blinking white light.

A flashing white light indicates the gateway is attempting to connect to your wifi network.

Sometimes the rainbow flash after factory reset does not happen, the light will just go off. This is a known bug we are working to resolve in the next version.

What is the security type of the WiFi network you are attempting to connect the gateway to?

Also you should be able to press and hold the CFG button until the LED turns Blue, that will put it into setup mode. If that does not work then disconnect power from the Gateway, hold down the CFG button, then re apply power, continue to hold the CFG button until the LED turns blue and that will force it into setup mode so you can connect to the Gateway via WiFi and access the configuration page. I highly recommend using Google Chrome for the configuration page, IE has some strange issues.

@TravisE_NCD_Technica thank you for your response.

I tried two computers (windows 10 using chrome) with no luck but it likes my IPhone so I am using that to setup. I got as far as red led coming on and staying lit for 10 seconds then off and back on for 10 seconds.

I have tried multiple wifi connections, right now I am trying a basic hotspot for the WIFI connection.

Below is a screenshot of my setup page before saving:

If the LED is flashing Red that sounds like the Gateway is not able to authenticate with the Ubidots server.

Take The MQTT Gateway out of the equation for a moment and try using a simple MQTT Client like MQTT.fx here and see if you are able to connect using it:
Use the same credentials with it you are using with The MQTT gateway and see if you can connect or not.

@TravisE_NCD_Technica it appears I am not having any luck connecting trying with the MQTT.fx

I would recommend contacting Ubidots to see if they can help. We really can’t provide technical support for it since it is not our product.

@TravisE_NCD_Technica, I am working with Ubidots and I shared the same snapshot above with them and all looks correct, but they are curious about the purpose of the last two fields:

  • End Node Publish Topic
  • End Node Subscribe Topic

Those topics will not be used unless you have an end node product which you more than likely do not as we currently only sell a 4 channel relay controller in the End Node product line.

Ok got it.

I was able to get a solid green light when I switched DHCP on as mentioned in this post.

I have the preventative maintenance sensor and I have opened it and verified sensor switch is in on per the documentation and verified batteries are full charge as well.

That all appears to be correct. A Green LED indicates the gateway is connected to The MQTT Broker. I’m not sure what else the problem could be other than the sensor being too close to the gateway(they cannot be that close when the antenna is installed on both units. You can move it about 10 ft away or remove the antenna from either the gateway or the sensor.

One last thing you can try is to put the gateway back into setup mode. Then open it’s web interface. On the web interface go to the devices tab and then press the reset button on the sensor. After a few seconds the sensor should appear there on the devices page, if it does not then there may be a communication issue of some sort.

@TravisE_NCD_Technica, I will try this right now.

Should I keep DHCP on or off?

I’d recommend keeping DHCP enabled

@TravisE_NCD_Technica, I got the gateway to finally talk to Ubidots, but it only publishes one time if I remove power then plug back in.

I left it on all night and there was no publishes to Ubidots.

I got the sensor to publish to Ubidots once but it was doing some weird antenna off touching antenna connection magic.

I for sure have switch turned on and have sensor 20ft away (both gateway and sensor antennas connected).

When I go into configure browser (still having to use Iphone, cannot get it to work on PC) I have to hold down “R” button on sensor for a few seconds then let go to try and get sensor to show up on gateway list. It shows 94% bat. and 100% signal. I try pushing the configure now button in the menu but it changes to configure now and nothing happens.

Bottom line:

  • WiFi is good
  • Gateway is good
  • Ubidots MQTT is good
  • Xbee communication side seems to be struggling

Hopefully I am missing somthing simple, thank you for your help.

@Bhaskar do you have any input on what could possibly be going on here?

can you check the u.fl antenna connector. make sure its not loose.

in order to configure the sensor please follow these steps

  1. press release reset button
  2. hold the cfg button for 5-6 sec and release cfg button

this will put the sensor in cfg mode


@Bhaskar and @TravisE_NCD_Technica, I think it is a matter of the power level of the radios.

I moved the sensor kit down a floor and on the other side of the building and now it is reporting on a 10min interval with RSSI of 26. I think it could be a matter of the radios being overpowered with signal, have you all experienced this before?

The best analogy I have heard regarding having high power radios to close to each other is its like screaming directly into someones ear “can you hear me?!”

yes that true… these wont work if they are too close (radios are too powerful).

I have spent countless hours fighting this thing and still i make this mistake atleast once a month :slight_smile:

if you are planning to use in close proximity than i would recommend reducing the wireless power.