MQTT Gateway Not Publishing to AWS MQTT Test

I have been trying to receive vibration and temperature data on AWS using the MQTT gateway. However, there is a problem. Here are the steps which I tried:

1 ) In order to verify the certificates and attached policies, I have created a virtual thing (AWS) on PC and with the help of a python code, it was possible to visualize published data on the MQTT test.
2 ) I have configured the sensor ( - vibration and temperature) with MQTT gateway using the validated certificates from step 1.
3 ) Checking on the system’s own software if the sensor sends data – positive.
4) Checking on AWS if a connection is established - positive.
5) Testing to check if the MQTT Test will read in any data when subscribed - negative… No data is received. MQTT LED goes steady green for few seconds, then flashing blue again .

I have read the similar topics and will try to update the firmware. However, just wanted to double check if anyone experienced and hopefully solved the issue. Thanks. Mert

Hi Mert,

It would be very strange for the Gateway to establish an MQTT connection with the broker and then for no reason revert to configuration mode(blinking blue led).

Are you saying you can tell for sure that the gateway is establishing a successful connection to the AWS MQTT Broker?

Hi Travis,
Thanks for the reply.
I am checking the connection from AWS cloudwatch – metrics. Please check the attached picture.

Color change is as mentioned. Thanks. Mert

What settings do you have entered in the MQTT Gateway under Message settings? That determines what topic transmissions a published to and what format the messages are sent in. You can send a screen shot of those settings if you like.

I leave them as default. Please check the attached snapshot. Thanks.

Hi again, did you have time to check ? thanks