MQTT Change Delivery Interval

I need to set the interval on my MQTT sensors to deliver data every 15 minutes as opposed to the default of 10.
I have the option under Sensor Settings on the Gateway Config page to change Delay to 15.
I also have the ability to set each respective sensor delay. I set them both to 15 and then switched them up, one at 10 and one at 15, but I am still getting readings every 10 minutes.
I have power cycled the Gateway after making the changes.
Thanks in advance for any assistance.

@travis1 might be able to help with this

I beleive you put the sensor in configure mode and then sent configuration parameters from gateway.


Have you consulted this guide that covers configuring sensor settings through gateway devices:

Hi Travis,

I have followed the steps, I set the interval to 15.

I am still unsure of the reset button, but I followed this thread and used the power switch (Ironically a different Kurt) MQTT Gateway with PR52-33N
It appears as though this is correct as I got to the next step(STATUS LINK).

I got an error when checking the status, but as per guide errors are common. (Setting the following commands failed: Undefined)

Now the device is returning readings every 30 seconds.
I have tried reverting to 10 mins, but it stays now responding at 30 second intervals.

I have rebooted both the gateway and even pulled the batteries from the sensor.

Am I using the proper method to remove the sensor from config mode with the power switch?
Any ideas on what is going wrong here?

To put the sensor in config mode do the following:

Make sure the sensor is powered up, switch inside is on.
Press and release the Reset Button.
Press and hold the CFG button immediately after releasing the reset button.
Hold the CFG button for approximately 8-9 seconds.
Release the CFG button.
The sensor is now in CFG mode.
To exit config mode press and release the reset button.

I have tried these steps again and used the R button for reset instead of the power switch.
I still got the STATUS link to appear. I still got the same error.
I am still getting readings every 30 seconds on MQTT FX.

EDIT: I see it is now every 11 seconds per reading

just to make sure the delay value is sec.
so in order to set to 15 min you will need to send 900sec.

That worked. I had to set it to 900 on the sensor and the gateway.
I was confused. At first the setting was at 10 and I was getting a reading every 10 mins.
Thanks for your help!!