MQTT AC current monitor not entering config

I just unboxed a new MQTT WiFi AC current monitor and cannot configure it. I have tried pressing and holding down the RST and CFG button and cycling power multiple times and nothing seems to happen.
I see the following when power is applied:
-Solid red/blue LED for 2 seconds
-Solid green LED for 10 seconds
-Green LED flashes 9 times
-Red LED flashes twice continuously

Am I doing something wrong???

The CFG/RST buttons on this device are not functional. You will need to locate the C/R buttons near the USB connector on the wireless module inside the sensor.

  1. Disconnect power
  2. Remove top cover.
  3. Press and hold the C button on top of the wireless module(near the USB connector).
  4. ReApply power.
  5. Once LED turns Blue release the C button.
  6. The LED should now begin flashing Blue indicating it is in configuration mode.

Great I am now in configuration mode but I’m stuck again!
I see the SSID and I can connect to the WiFi network with my Win10 computer using the password in the user manual.
A browser window opens but it’s not able to connect. I tried connecting to IP address per the manual but that doesn’t work either!
What should I do next?

Are you entering NCDBeast as the password? Try using Google Chrome web browser.

OK I was able to get the web configuration page to load after multiple power cycles!

Now I am unable to get the device to connect to wi-fi. I entered the credentials for a known working wi-fi network and clicked Save Settings. The LED goes off for three seconds, turns green for one second, then goes back to flashing blue.

I have also tried:
-Pressing reset, config, and power cycling the device
-Turning off DHCP and using a fixed IP address in the wi-fi subnet
-Entering the connection info for the MQTT broker
-Factory reset and repeating everything

The device sometimes blinks yellow but always returns to flashing blue and my wi-fi router does not show that it ever connects.

What should I do now?

Hi Joe,

I wonder if it’s some sort of issue with the MQTT Broker. Could you try entering these credentials:

MQTT Host Domain:
MQTT Port: 1883
MQTT Username: token:token_EKBovij7uFArKIPW
MQTT Password: Leave Blank
Topic format: Article_Channel/::Sensor_ID::
Messsage Format: ::Sensor_Data::

This will connect the sensor to my broker which I am subscribing to.

If this results in the same issue you might check to be sure your network firewall is not blocking connections over port 1883 as that could cause the device to be forcibly disconnected from the network.

I think it is working now. Are you seeing data on your MQTT broker?

I fiddled around with it quite a bit and what seemed to make it work was to manually type in the wi-fi SSID in the “Hidden Network” field. Is that a known issue?


Sorry I lost internet connectivity for a minute there. I just got my MQTT Client connected again and am monitoring for messages. I have not seen a message yet but I do not know the report interval of your sensor.

What is the SSID of the network? Does it contain special characters or anything strange like that?

Update: I did see a reading come through at 8:47 AM CT with a current reading of 0. So the sensor is functioning. And publishing messages to my broker.

I am very close to getting this working but not quite there yet.

Since last post, I discovered a few more things:

  1. I did not need to enter the hidden SSID to connect to wifi. Not sure why it wasn’t connecting to wifi initially but now it’s working.
  2. I am using a LAN so my MQTT broker just has an IP address and not a URL. To connect to the broker, I needed to enter the IP address in the “Domain” field in the device settings. I left the IP address at and it connected. Entering the IP address of the broker in the IP address field does not work–I have tried this multiple times and it is repeatable.
  3. The device always connects to wifi using DHCP whether the DHCP box is checked or not. If I uncheck the DHCP box, enter valid settings for the gateway, subnet mask, and static IP, I can see with Wireshark that the device still requests and is granted a DHCP IP address. When I reconnect to the device settings, DHCP is checked again. I don’t think this is a problem with my particular application but I noted this when I was experimenting with different settings.

So now the device IS connected to my MQTT broker and is blinking green. It is configured to publish ::Sensor_Data:: every 5 seconds on a topic called “test” that I am subscribing to. The problem is the device does not publish its data regularly. In 30 minutes of resetting and power cycling the device, it published to the broker a total of 2 times. I received valid messages in an MQTT client and could also see the MQTT publish messages in Wireshark. However, those were the ONLY 2 times the device published data in 30 minutes. I can see in Wireshark that the device is publishing MQTT ping messages every 15 seconds, but is not publishing any sensor data other than the 2 instances.


Hi Joe,

It sounds like our production department did not load the correct firmware into the IC on the board. This means it works perfectly fine but you cannot update the interval it reports at(it is stuck at 10 minutes). I will absolutely bring this to their attention.

The Domain/IP fields is a known bug. If anything is entered in the Domain field, then later the user tries to switch to using the IP field it will not work, it always tries to use the domain field info even if it is blank. The fix will be to remove the IP field all together and just have the domain field renamed to host since it will work with URLs or IP addresses.

As for the DHCP issue I am not certain what is going on there. I will investigate that issue in the firmware given the information you have provided.

I would recommend sending the device in for RMA repair so we can update the firmware in the on board IC. To do that you can complete the RMA form here:
I can correct some issues remotely with you but if you need that report interval changed it’s going to have to come back here to be re-flashed. This requirement is being remedied in the next version of the product currently in development.

Thank you Joe,
Travis Elliott

We are going to send it back to have the correct firmware loaded. We were able to get some valid current readings with it so it seems to work other than the reporting interval.

Thanks for the support Travis.

Hi Joe,

Did you fill out an RMA? If not that can be done here:

We submitted an RMA about 4 days ago but have not heard back yet

Hi Joe,
What is your RMA number ?
make sure you are submitting using this link

I filled in the form at the link and a message appeared saying you would get back to me. That was around 4 days ago. I don’t think any RMA number has been provided yet.

we can not find any RMA linked your account. can you resubmit the RMA.

it will look like this

I just submitted another RMA. I received a message stating “The form was sent successfully”.

You should be getting an email with return instructions.

I shipped the sensor back to you about 2 weeks ago under RMA #18465 and have not heard anything further.

Can you confirm that you received it?