Modbus stop bits


is there a way to set the RS-485 modem up to send and receive messages using 2 stop bits? we have an older VFD that requires the Modbus 8-N-2 protocol. the current in use for other VFDs, and standard on the modem (as i read in your article) is 8-N-1.


command to set stop bit to 1 –
7E 00 14 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F4 22 00 00 17 00 C7
set stop but to 2
7E 00 14 10 00 00 00 00 00 00 00 FF FF FF FE 00 00 F4 22 00 00 17 01 C6

unfortunately this resulted in the network ID being reset to 7FFF. not sure if the initial command worked, but this it now on the wrong network.

this command should not interfere with network id.

what network id you want to set to?

I know it shouldn’t, but it changed it nonetheless. I have run the command to change it to 7AAA again, but without success. we have had issues with this in the past too on these RS-485 modems, where the command did not stick. I have succesfully tested our communication with the wired RS485 transmitter with comm operator so we know our command and settings on the vfd are correct. it just doesn’t work with the wireless transmitter, because the stop bits seems to have been left unchanged.

firmware 0 had an issue with network ID storage. we only had a handful of them out and recalled them.
when you send the network ID command what response do you get ?

here is how confg mode works

  1. reset the RS485 modem
  2. it will send “FLY” packet
  3. it will stay on next 60 sec
  4. during this 60 sec users can send any commands to set any parameter
  5. once it timeout it will go in operation mode

did not know this was resolved with new firmware. i was just able to change the network id back to 7AAA. stil not able to get a message from the VFD though. Attached a screenshot of what the Comm operator looks like. when the message is sent straight from there, you can see we get a response from the VFD. however, when it is sent from Node-Red, there is no response. i think it has to do with the stop bits, but cannot confirm.

When sending the above mentioned packet, i get the following result:

2nd last byte is FF which means the parameter was set successfully.
is this the VFD which needs 2 stop bits ?

this is on the RS-485 modem that connects to the VFD has only has a two bit option. if this was not the solution, do you know any other issue there may be with the modem vs the hardwired connection? i have attempted to use another modem as well with no luck.