Micro Gateway Configuration


We’ve received a Wifi Micro Gateway MQTT and are trying to configure it but it seems to always go back to configuration mode. I understand that for it to not be in Config Mode, it has to have WiFi and MQTT properly configured, which for all that I can say it has.

I tried using both the office Wifi and Home wifi just in case there was an issue with authentication, but still the same.

Any idea what could be the problem?



Is there any way you can provide screen shots of the settings you are entering into the MQTT Gateway prior to clicking the Save Settings button?

Hi Travis,

I seem to have made it work using the details for a free MQTT broker I found online.

A device called “espressif” joined the network. However, now the LED turns red for around 35 seconds and then goes off for around 40seconds and then repeats. I also can’t see the Micro GW WiFi anymore.

Could the red LED be due to no sensors being connected to the gateway? How do I do to access the gateway Configuration page again? Is there a place where tis documentation can be found?


From my memory
The RED led usually indicates bad username and password, or at least trouble talking to the mqtt broker.
Blueish whiteish is usually trying to join wifi.
Green is good and connected.
Blue is config mode.

If you use a tool like MQTT Explorer, are you able to connect to that broker with the config in the screenshot (no username and password)?

Hello, I used the mosquitto “Connecting the MQTT Gateway to Mosquitto” tutorial and managed to get the Gateway sending data to my PC. However, for some reason I don’t see the sensor data, I only get gateway information (like mac, ip, bee_address, network_id, preamble, tx_power and bee_ready) but no data being transmitted from the sensor (CO2 one).

Also, most of the times when in configuration mode I need to full reset the sensor (reset + cfg (20sec)) for that sensor to appear in the gateway list, if not just pressing reset does nothing, which is really annoying.

So in all honesty I’m not sure if the sensor is really doing anything, I mean, I can see data while on Configuration mode in the gateway but I’m not sure if it is pushing any data afterwards. Information overall is quite limited to be honest.


In addition, for some reason the sensor type does not populate, I’m wondering if the sensor is working correctly.

I’ve tried a few more times to get this working and now the configuration has even stopped working. I get Status failed all the times I have tried but no information as to what to do.

Could you provide information on how to properly configured the sensor?

My experience so far trying to follow the " Sensor Configuration Using Micro Gateways" procedure:

  1. the sensor does not appear just by clicking reset, only if I do rest + cfg (20 seconds), which I understand it does a hard reset. but even this does not work sometimes.
  2. The transmission counter always stays at 1, even if I leave the sensor for a while (20-30min) just talking to the gateway. Also, pressing reset for it to trigger another transmission does not do anything.
  3. The “Success” in the config that I saw a few times before now always says “Status” and failed in the description but without any added information.
  4. Even when the sensor was configured correctly data failed to be sent through MQTT, I only get the initial values from the gateway but no sensor data.

Overall not a good experience so far for a 300 us device that has 3 configuration parameters and two buttons that are are only able to do three things:

  1. Reset
  2. Config (reset + cfg (8 sec))
  3. Hard reset?? (reset + cfg (20 seconds)

I would have expected the configuration to have been extremely simple.

PS: Is there a factory reset for the sensor? I would like to try to wipe it and let it boot from 0 again.