Mega Modem QC issue

The Mega Modem I received has a functional quality issue. The power barrel jack is offset from the hole in the enclosure by ~4mm. I cannot plug the barrel jack into the module because it interferes with the case.

I loosened the screws holding the board on the base of the enclosure to plug in the barrel jack and the modem still will not power up. The modem will not communicate with the thermocouple module I purchased even when using the simplest Node Red example and power through the USB. Not so happy with the quality control. I was trying to use the NCD three channel thermocouple sensor and Mega Modem for a time sensitive project. Unfortunately, I will need to quickly figure out a different solution and return these items.

Hi Casy,
Is the thermocouple powered up ?
It has a switch/jumper which needs to be on “ON” position in order to power up the sensor.

@jacob @travis1 can you take a look at this.


Yep. The issue is that the barrel jack is offset from the hole in the case and cannot accept the power plug becasue it interferes with the case. The USB port will power the modem - or at least the top ESP board, however, when I was able to plug in the barrel jack by removing the screws that hold the base board to the case, the barrel jack will not power the modem. I have to assume there is something wrong with the barrel jack.

this product can be powered by USB port as well.

Mega modem sends data over TCP/IP so you can use Alpha station to view the data as well.

can you send a picture of the bad power connector you have so that we can arrange an advance replacement for you while you get the software part going.


Attached are the pictures you requested.


Were you able to read the sensor data while the modem was powered over USB ?



If you’d like a replacemnt can you fill out an RMA form at:

We have approved sending you and advanced replacement so you can ship us back the defective modem when you receive the replacement modem.

Unfortunately, no. I tried connecting through TCP/IP and COM port using Alpha station. I checked and re-checked the configuration of the modem, but no luck. It simply states: “Unable to communicate with the modem.” The IP does auto-populate as it should in Alpha Station, but the error message is the same no matter the method I try to use to connect.

I believe in order to connect it through USB you will have to disable TCP/IP.

@travis1 do you know why it wont connect?


Hi @casey.beeler,

What is the LED on the modem doing? It should be flashing a color.

Also I do not recommend powering the Modem over USB. It should be powered via the 2.1mm power jack. If you connect power through the 2.1mm power jack with no USB cable connected does the LED turn on at all? If not can you send detailed photos of the top and bottom of the Gateway circuit board?

Hi Travis,

I am having similar issue. I was able to connect once but after that keeps saying “Unable to communicate with the modem.” How do we do the factory default? or how to get it working again? I need an answer ASAP.

Thank you

To perform a factory reset put the Modem into configuration mode by pressing and holding the CFG button in the modem until the LED turns Blue. Once it is Blue release the button. Once the LED begins flashing Blue press and hold the CFG button again until the LED flashes random colors. The Modem is now factory reset.

Thank you,