Lantronix XPortPro WEB-i Webpage does not display

Even after a reset of this device, it picks up an IP address, I can ping it, but fails to provide a web page. Browser error message states

" Version:1.0 StartHTML:000000193 EndHTML:000001225 StartFragment:000001008 EndFragment:000001157 StartSelection:000001008 EndSelection:000001157 SourceURL:res://ieframe.dll/http_403.htm

This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage."

I can connect to the Lantronix XPortPro via Telnet, but it is at uClinux Login prompt and I am unable to find any credentials to provide, webi and 1234 do not work. I have multiple Lantronix in this same predicament. Base station software fails to recognize the device.

Can the web page on this Web-I be recovered?


Can you try accessing something outside of the home page and see if that comes up?

You can try: http://yourIpAddress/ProXR/DeviceConfiguration.html

If that comes up can you try to change the default page home page to something else other than what it currently is, select the update button in that section, and click on reboot at the top.

If all of that worked, at this point do you still get the 403 forbidden error?

I forgot to mention you change the default home page under the “Choose which page you would like the Web-i to bring up as the home page” section on the Device Configuration page.

Yes I was able to use the URL and set Network as the home page. I will try to redeploy it to the location and see if it works. TCP Socket Listener lost its port number which I have added, but NCD Base station software is still unable to recognize the Web-I device.

When you say it lost its port number, do you mean that the port number was blank?

If that’s the case it sounds like perhaps the configuration files were corrupted. It may be ideal to reset them using this section of the Web-i guide:

If Web-i Interface pages do not display all content:

Enter the following sequence into the address bar of your web browser: http://deviceIPAddress/cgi-bin/ This will reset the configuration files for the device. The device will then have to be reconfigured.

Was this device available over the internet when this issue started happening?

Device is failing to retain a statically defined IP address, even configuration shows it is now static, but actually it has picked up an address via DHCP.

linked worked in the sense that it set all the parameters back to default, but device fails to retain statically defined IP address.

Unfortunately I don’t believe that can be fixed without coming back to NCD for evaluation.

The best I can do is recommend an RMA: and get you a replacement Web-i.

Reference this post in the issue and let our RMA department know I’ve authorized a replacement Web-i.

I have about 4 to 5 Lantronix in that predicament, I will start the RMA process. Thanks for your help.

Hi Tazmir,

I received the RMA and can confirm at least one issue.

We’re building you replacements, but these will eventually run into the same issue as we have yet to track down the issue. The developer of the backend of these modules is currently out of country, but should be back soon.

If you’d prefer we can ship you a few replacements and ship the rest once the issue is resolved. If so just let me know how many you want immediately.

Jacob, I have more of these Lantronix with similar issue, can their issue be resolved with a patch since I can go to their site using a complete path rather than just the IP. Would I have the ability to fix these?. If not, then can I send these to you using the same RMA number or you will have to open another one. Let me know, thanks