Issues Configuring Vibration Sensor V3 (PR55-61E) to Raw Mode on Enterprise IIoT Gateway

Dear NCD Support Team,

I’m working with the NCD Industrial IoT Vibration Sensor V3 connected to an Enterprise IIoT Gateway. I’ve successfully utilized the sensor in both processed and processed with raw on-demand modes for several months. However, I’m facing errors when attempting to configure the sensor to raw data mode within Node-RED.

Error Description: After configuring for raw mode, the sensor indicates an error with two periodic LED blinks.

Steps I’ve Taken:

Request: Could you please assist me with the following:

  1. Troubleshooting: Are there known issues or common configuration errors when switching to raw mode that I should be aware of?
  2. Log Analysis: Would it be helpful if I provide logs from the Enterprise IIoT Gateway or Node-RED to help diagnose the issue? If so, please let me know the best way to capture and share this information.

Additional Information of my sensor settings on Node Red:
Destination Address: (I have set it using the last 8 digits of the MAC Address provided by gateway as I hit configuration)
OTF: Enabled
Node ID: 0
Delay: 0
Retries: Disabled
Mode: RAW
Set On Request Timeout in seconds: Disabled
Set Sampling Duration: 40 (indicating 2secs)
Sampling Interval: 5 mins
Set RTC: Enabled
Low Pass Filter: Disabled
High Pass Filter: Disabled
Full Range Scale: +/-8g
Set Dead Band in mg: Disabled
Payload Length: 55 Bytes (I am using the sensor with 2.4ghz)

I need help on this issue asap. Please do instruct.

Kind regards,

did you set the correct destination address ?

Yes I am sure. I have been following the video link attached to the forum. I extracted the address same way done in the video. That is through the gateway mac address provided in debug message.

do you get FLY or run packet from the sensor ?

I get the fly packet, but the sensor then stays in config. I do not get run packet at all.

the fly packet is sent in broadcast mode.
there could be two issues

  1. destination address is not set correctly
  2. sample size is too large. set odr to 800


I’ve set it to 800 and it works.
What is the reason for it not working for a higher ODR and what could be done to have a higher ODR possibly 12800?

the sample duration is too long. set it to 5 ( 250msec)

Hi, I have tried sample duration = 5 and ODR = 12800.
The sensor still shows config complete.

What can be done about this?