Is ncd-red-ads1115 still usable with the latest version of Node-Red?

I’ve tried installing and get a ton of errors, I’m in over my head in figuring this out.

Can you provide more information?

Version of Node-Red
Version of NodeJS
Errors you are getting

I’ve started over, loading up a card with the most current Raspbian, going to get the latest Node-Red, will let you know what errors I run into.

Quick question, better to install from within Node-Red or use “npm install ncd-red-ads1115”

If you’re using Node-Red then its easiest if you install it through Node-Red’s pallet manager.

Got it figured out, Comm type needed to be I2C Bus, not NCD USB

1 Like

Hi @darinschollmeyer,

The SerialPort library which our library depends on only supports nodejs up to version 12.20.1. I believe you have a later version of NodeJS. You can use node version manager(NVM) to roll your nodejs version back to 12.20.1

That’s what I needed to know, thanks!

Rolled it back, still not installing.

What is the error thrown during installation?

If you enter node -v in the terminal on the Pi what is the response?

It shows v12.20.1
I can’t post the link to the .log, but it looks pretty much like it did before.
446 verbose Linux 5.10.52-v7+
447 verbose argv “/usr/bin/node” “/usr/bin/npm” “install” “–no-audit” “–no-update-notifier” “–no-fund” “–save” “–save-prefix=~” “–production” “–engine-strict” “ncd-red-ads1115@1.2.7”
448 verbose node v14.17.5
449 verbose npm v6.14.14
450 error code ELIFECYCLE
451 error errno 1
452 error @serialport/bindings@2.0.8 install: prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
452 error Exit status 1
453 error Failed at the @serialport/bindings@2.0.8 install script.
453 error This is probably not a problem with npm. There is likely additional logging output above.
454 verbose exit [ 1, true ]


Navigate to the .node-red/node_modules directory. Then run command npm install serialport and let me know what you find there.

2021-08-25T20:40:11.864Z Install : ncd-red-ads1115 1.2.7

2021-08-25T20:40:12.057Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict ncd-red-ads1115@1.2.7
2021-08-25T20:40:23.382Z [err] npm
2021-08-25T20:40:23.383Z [err] WARN checkPermissions Missing write access to /home/pi/.node-red/node_modules/serialport
2021-08-25T20:40:24.044Z [err] npm
2021-08-25T20:40:24.045Z [err] ERR! code ELOOP
2021-08-25T20:40:24.045Z [err] npm ERR! syscall access
2021-08-25T20:40:24.046Z [err] npm ERR! path /home/pi/.node-red/node_modules/serialport
2021-08-25T20:40:24.047Z [err] npm
2021-08-25T20:40:24.048Z [err] ERR! errno -40
2021-08-25T20:40:24.067Z [err] npm
2021-08-25T20:40:24.068Z [err] ERR! ELOOP: too many symbolic links encountered, access ‘/home/pi/.node-red/node_modules/serialport’
2021-08-25T20:40:24.097Z [err]
2021-08-25T20:40:24.097Z [err] npm ERR!
2021-08-25T20:40:24.098Z [err] A complete log of this run can be found in:
2021-08-25T20:40:24.098Z [err] npm ERR! /home/pi/.npm/_logs/2021-08-25T20_40_24_077Z-debug.log
2021-08-25T20:40:24.117Z rc=216

It looks like for some reason the install command is requiring root access permissions. Try running the command with sudo.

It installed the serialport ok, the log on the previous post showing is from trying to install “sudo npm install --unsafe-perm ncd-red-ads1115”

pi@raspberrypi:~ $ cd .node-red/node_modules
pi@raspberrypi:~/.node-red/node_modules $ npm install serialport

  • serialport@9.2.0
    removed 3 packages and updated 1 package in 21.874s
    pi@raspberrypi:~/.node-red/node_modules $

I’m not sure what the issue is but you have some sort of permission issue. This may be related to the way node-red was installed but hard to say for sure.

I used: ```
bash <(curl -sL

to install update node red and nodejs