IOT Edge Computer Wireless Connectivity

I have an IOT Edge Computer (PR55-36) and am trying to connect it to a MOXA wireless access point. I have the SSID/passkey/protocol from the MOXA and have entered it into the wi-fi section of the Network tab, however the I/O on the Edge device consistently says that wi-fi is “down”.

Is there any documentation on how to connect this edge device using Ethernet/Wifi? The steps at https://ncd.io/lte-cellular-ethernet-wifi-iot-edge-computer/ are not working for me.

  1. Connecting to Ethernet is straight forward. plug the Ethernet cable and select Ethernet as your network.

  2. same goes for wifi. make sure your id and password are correct. ( case sensitive).

you can share a screenshot of your settings and we can take a look

I am having a similar problem.

This are the steps I do and what it happens:

  1. I turn on the IoT Edge Computer
  2. I’ve got no Ethernet cable so I connect to the IoT edge Device AP
  3. Go to the address that appear on the screen “192.168../Network”
  4. I add the Wifi SSID & password (in a case sensitive manner) and press submit
  5. Pop appears saying “Wi-fi parameters changed”
  6. Page refreshes and the Wifi parameters are blank.

What web browser are you using? I would recommend Chrome, Firefox, or Safari.

I’m using Chrome as a browser

What does it say next to WiFi under Network Control next to WiFi? Does it say Disabled, Up, or Down? If it says disabled try refreshing the page. It takes about a minute after storing WiFi settings before the WiFi connection can be made.

It says down.

(Apologies for late reply, I did not receive a notification about your reply)

Open the web interface to the IoT Edge Computer.
Click the Network Tab.
Click WiFi.
Click the SSID Field.
Enter the Network SSID.
Enter the Network Passkey.
Select DHCP as Protocol.
Click Submit.
After approximately 5 minutes the IoT Edge Computer should connect to the WiFi network. If it does not then attempt rebooting the IoT Edge Computer.
If WiFi is still Down please let me know what type of Security the WiFi network utilizes(Open, WEP, WP-ASK, etc). Also please confirm if the network is 2.4ghz or 5ghz.

Tried the steps you mentioned but WiFi still Down.

Here some details of the WiFi:

  • Protocol: Wi-Fi 4 (802.11n)
  • Security type: WPA2-Personal
  • Network band: 2.4 GHz
  1. How far is the IoT Edge Computer from the AP?
  2. Have you confirmed, on another device, the WiFi network credentials you are entering into the IoT Edge Computer to connect to the AP?
  3. Have you attempted to connect the IoT Edge Computer to another AP for troubleshooting purposes? Something like a simple home WiFi Router?
  1. The IoT Is right next to my laptop and the router.
  2. Yes, is the house WiFi so I have my laptop & phone connected to it.
  3. I have tried connecting to a hotspot from my phone but that didn’t work either.
    Details of the hotspot:
  • Security type: WPA2-Personal
  • Network band: 2.4 GHz

Can you connect the IoT Edge Computer to the router via Ethernet to see if that works?

Can you provide screen shots of the Network settings on the IoT Edge Computer?

Yes, connecting it via Ethernet works fine.

When I input the WiFi settings it shows me a pop-up message, refreshes the pages and the WiFi settings are blank again

Hi Marc,

We have not had this issue with users in the past. I am not sure what could be causing this.

You can however force these WiFi settings manually through the terminal. To do this:

  1. Click Terminal to open the terminal interface to the IoT Edge Computer.
  2. Log into the terminal, username root password ncdio
  3. In the terminal enter:
vi /etc/config/wireless
  1. Press i on your keyboard to enter vi insert/edit mode.
  2. Under sta section set:
    option disabled ‘0’
    option encryption should be set to the security type of the network.
    option key set to the password for the WiFi network
    option ssid set to the name of the network.
    Also set encryption, key, and ssid under wifi-config section. Also set disabled to 0 under radio0 section.
  3. On your keyboard press the ESC key, then type :wq to save changes and quit vi.
  4. In the terminal enter reboot to reboot the IoT Edge Computer. Upon reboot it should connect to the WiFi network.

I don’t seem to have a wifi-config section under the vi /etc/config/wireless section

Enter wifisetup in a terminal and you’ll see the following output:

root@Omega-2757:/# wifisetup
Onion Omega Wifi Setup

Select from the following:
1) Scan for Wifi networks
2) Type network info
q) Exit

Selection:

You can enter 1, and your Omega will scan for available networks:

Selection: 1
Scanning for wifi networks...

Select Wifi network:
1) BYB
2) studio sixteen
3) EG Energy
4) mayaaa
5) Authentic
6) OnionWiFi
7) Orpheus
8) Omega-18C2

Selection:

Enter your selection and you will be prompted for a password if required. Your network authentication type will be automatically detected in the scan:

Selection: 6
Network: OnionWiFi
Authentication type: WPA2PSK
Enter password:

Enter your password, and hit enter. Your Omega’s network adapter will restart and attempt to connect to the new network.

Since the network adapter is restarting, the Omega’s AP will go down and be inaccessible during this period, but it will come back up in roughly 30 seconds.

I am experiencing the same issue as @marc.hernandez when attemtping to setup wifi. Any settings entered on the network tab for WiFi are blank except for dhcp. I changed it to static and input network settings and was successful but I prefer to use dhcp. Thought it would be helpful to know that the issue is not isolated to a single instance.

Thanks Bhaskar,

That did work.
Just as a note, the encryption type is psk2 not WPA2-Personal as it showed in my laptop.
Maybe that is what it was causing the problem on the vi /etc/config/wireless route.