Iot Edge Computer unable to connect to LTE network

I am trying to connect my IoT Edge Computer through an LTE network (Hutch) in Sri Lanka.
I have talked to them and they mentioned they don’t have a configuration for Linux based devices.
Is there any other configuration that might work?

This is the 2 APN setting options that I get with the SIM card on my phone:

Besides that I’ve also found configuration options here.

I’ve created a new chatscript ( with both APN name options (internet & hutch3g) without success.

Do you have any recommendations what other LTE settings I should try?

Also, should I configure it with the APN protocol or the APN roaming protocol?


looks like your apn name is internet not hutch3g.

I have tried the same settings but with apn name internet and still didn’t work.

Any other suggestions?

what is the AT+CGDCONT value for this provider.
if dont know try 0 and 2 as well
first time connection might take upto 30min. so wait for 30min before making next change. and also reboot after making a change

1 Like

I’ve tried with both values (Waiting 30min in between & rebooting the IoT computer) without success.
Any other alternatives?? Could it be any Modem configurations?

This is what appears on the LTE Network settings:

what is the IPV setting for the network ?
I have no knowledge of this network provider so just throwing ideas out there. Generally network provider provides all this info and we just use them as it is.

On the images of the first post it gave me 2 options: IPv4 & IPv4/IPv6

I’ve tried both “IPv4” & “IPv4/IPv6” without any luck

I have also tried with this other provider (dialog) with the same lack of success

I’ve tried IPv4 and IPV4V6 + AT+CGDCONT 0 and 2

if we dont have the correct setting then its like shooting in the dark.
i will recommend going with hologram. they have coverage in srilanks

I have received the settings from them:

  1. CMO profile (UNMOPROF)
    • Select default profile “0”

2 AT+CGDCONT (an example here for Singtel is AT+CGDCONT=1,”IP”,”e-ideas”)
• AT+CGDCONT=1,”IPV4″,”Internet”

When trying to change the UNMOPROF value to 0 or change the modem profile to the values seem to stay blank.

Is there any way to set them up via terminal??

Default umnoprof is 0.

also in order to view the modem setting.

  1. go to network tab
  2. select ethernet as you network
  3. go to modem tab

if you have the LTE enabled and go to modem tab then it will be blank because hardware serial can only be accessed by one routine at a time.

1 Like

I have connected to the WiFi and the modem tab still blank.

I have been trying to connect to the Hologram LTE and after factory reset it is still not connecting. Not sure if the modem issue has something to do with it?

When I go through the terminal and run modem_info.lua I get the following message:

status: ERROR
ati: timeout

I have done a factory reset just before trying that, so not sure where (or if) the problem comes from that.

after factory reset did you reflash the firmware ?

I followed the instructions in section 6 here

But did not reflash any additional firmware after that.

i am assuming you had an ethernet hooked up to the edge pc while loading firmware ?

Yes, the ethernet was connected to edge computer

can you share screenshot of all tabs

Here the System, Network & Modem tab:

in the network tab
select ethernet as you communication network and then click on modem tab