IoT Edge Computer receive wireless data from wireless thermocouple sensor


I’m trying to connect with IoT Edge Computer to a Industrial Wireless Thermocouple High Temperature Sensor. I have the IoT connected to my WiFi and this is how my node-red flow looks like:

I have turned on the sensor but the IoT is not displaying any data received from it.
The Wireless Gateway, I’ve seen the Serial Device is /dev/ttyS1 but the Modem Type seems to be USB (serial).

I’ve tried to change the Modem Type to TCP (Ethernet/Network) with port 2101 but it doesn’t seem to work either.

Hi Marc,

Can you provide top down photos of the IoT Edge Computer and the sensor both with lids removed?

Hey Travis,

This is how the IoT looks.

IoT Edge Computer:

(it is currently plug into my laptop but I want to receive the information via WiFi)

Industrial Wireless Thermocouple High Temperature Sensor:

The pin is away from the “PS” setting, which if I understood correctly that is how it starts to transmit.

Upon further trying I’ve seen I get a “Failed to connect” message from the Wireless Gateway:

I have tried to do a factory reset from the IoT Edge Computer but I still get the same failed to connect message. (The configuration has not changed as per the image on the problem description above)

One thing to (maybe) notice is that the IoT Edge Computer has only a red LED on. There is no green LED on anymore.

can you share the wireless gateway settings ?
want to make sure you are using correct port and the baudrate.

Hey @Bhaskar,

I’ve used the same that it came on the template “AWS Modem Flow”:

  • Modem Type: USB
  • Serial Port: /dev/ttyS1
  • Baud Rate: 115200
  • Network ID: 0x7FFF
  • RSSI to incoming packets: checked

I have tried to add a Wireless Device to see if I could get the sensor into configuration mode but I don’t seem to be able to get it into “running” mode. This are the configurations I used for it:

in the background i do see that the gateway node is now connected.
if you press rest on the thermocouple sensor do you see any data in the debug window ?

Yes, rebooting the IoT Edge Computer it showed as ready (and the green LED is on now), but no the debug window is not showing any data.

I will try to swap the batteries tomorrow, but as I got the devices less than 2 months ago (and use it rarely during the first one), they shouldn’t be out right?

the only way batteries can go down if the sensor was left in cfg mode mode and that will drain the batteries.

I didn’t even try to put the sensor in configuration mode until recently. So that is definitely not the case.

We use several NCD sensor types. Once you put in the new batteries…make sure that you have turned the sensor on…then press reset and now that you have the gateway running in node red … you should see an output in the debug window.

1 Like

quick questions – i do see a mac address filled out in the last screenshot you shared?
where did you get this mac address?
remove this mac address and redeploy the flow and then press rest

I got the mac address from the side side sticker of my thermocouple sensor. I figured it was the same as the mac address for the IoT Edge Computer is also on its side sticker.
I’ve try it without the mac address and the Wireless Device still doesn’t go to running.

@markcox new batteries and following your instructions don’t seem to send (or receive) data either.

I do get this message on my debug window:
"Error: ENOENT: no such file or directory, open '/root/certs/client-cert.pem.crt'"

Can this have something to do with it?

The error you are getting is coming from AWS node. You can ignore it.
did you try factory resetting the sensor ?

I noticed in the top down that the power toggle was set to external power on the sensor. Just to confirm that this power toggle switch is in the battery power position when trying to read the sensor data.

I’ve tried putting the sensor into config without setting any mac address but it did not work either.
Factory reset did not seem to change anything.

I have the pin the furthest away from “PS”. I found this recommendation here:

I have just manage to get it working.
I don’t know if I was doing the factory reset wrong or the antennas for both Iot edge & thermocouple where swap (I did both things before checking), but I have started to receive data from the sensor.

Edit: I have just seen that the power toggle has to be the closest to the “PS” in order for it to work. I must of misunderstood the text from the page I mentioned above. Thanks for noticing @jacob.